Re: What's cooking in git.git (Nov 2025, #10; Sun, 30)
- From
Patrick Steinhardt <ps@pks.im>
- Date
- Dec 1, 2025, 09:54 UTC
- Message-ID
- <aS1l0YuU9xOE7eog@pks.im>
- In-Reply-To
- <xmqq5xaqbxmk.fsf@gitster.g>
On Sun, Nov 30, 2025 at 09:05:07PM -0800, Junio C Hamano wrote:
Show 27 quoted lines
> * ps/object-read-stream (2025-11-23) 20 commits > - streaming: drop redundant type and size pointers > - streaming: move into object database subsystem > - streaming: refactor interface to be object-database-centric > - streaming: move logic to read packed objects streams into backend > - streaming: move logic to read loose objects streams into backend > - streaming: make the `odb_read_stream` definition public > - streaming: get rid of `the_repository` > - streaming: rely on object sources to create object stream > - packfile: introduce function to read object info from a store > - streaming: move zlib stream into backends > - streaming: create structure for filtered object streams > - streaming: create structure for packed object streams > - streaming: create structure for loose object streams > - streaming: create structure for in-core object streams > - streaming: allocate stream inside the backend-specific logic > - streaming: explicitly pass packfile info when streaming a packed object > - streaming: propagate final object type via the stream > - streaming: drop the `open()` callback function > - streaming: rename `git_istream` into `odb_read_stream` > - Merge branch 'ps/object-source-loose' into ps/object-read-stream > > The "git_istream" abstraction has been revamped to make it easier > to interface with pluggable object database design. > > Will merge to 'next'? > source: <20251123-b4-pks-odb-read-stream-v3-0-1a129182822b@pks.im>
I think this topic should be ready for next. The latest version didn't receive any feedback, but all it did is to improve some commit messages and rename a function based on previous reviews.
Show 20 quoted lines
> * ps/history (2025-10-27) 12 commits > - builtin/history: implement "split" subcommand > - cache-tree: allow writing in-memory index as tree > - add-patch: add support for in-memory index patching > - add-patch: remove dependency on "add-interactive" subsystem > - add-patch: split out `struct interactive_options` > - add-patch: split out header from "add-interactive.h" > - builtin/history: implement "reword" subcommand > - builtin: add new "history" command > - replay: stop using `the_repository` > - replay: extract logic to pick commits > - wt-status: provide function to expose status for trees > - Merge branch 'sa/replay-atomic-ref-updates' into ps/history > (this branch is used by pw/replay-drop-empty.) > > "git history" history rewriting UI. > > Expecting a reroll. > cf. <aRxDYkeAi8T-HH8M@pks.im> > source: <20251027-b4-pks-history-builtin-v6-0-407dd3f57ad3@pks.im>
I'll address feedback on this topic later this week.
Thanks!
Patrick