Re: [PATCH v4 0/5] maintenance: add an 'is-needed' subcommand
On Sat, Nov 08, 2025 at 10:51:52PM +0100, Karthik Nayak wrote:
Show 12 quoted lines
> Changes in v4:
> - In `update_segment_if_compaction_required()` change the argument name
> from `use_heuristics` to `use_geometric` since we only have one
> heuristic currently and this is much clearer to understand.
> - There were a lot of discussion on how to return a bool variable when
> the function has a return type of int. We discussed both '!!required',
> and 'required != true'. I'm going to punt this discussion keeping it
> simple as 'return required' as in my first version, since even Junio
> expressed his thoughts in favor of it.
> - Add a TODO for improvements to the flow when running `git maintenance
> is-needed` without the `--auto` flag.
> - Link to v3: https://patch.msgid.link/20251106-562-add-sub-command-to-check-if-maintenance-is-needed-v3-0-d611a2a95cf5@gmail.com
I'm happy with this version. Thanks!
Patrick