git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 01/17] object-store: rename `raw_object_store` to `object_database`

From
Patrick Steinhardt <ps@pks.im>
Date
Jun 4, 2025, 11:52 UTC
Message-ID
<aEAzZLgPWCGwdpiE@pks.im>
In-Reply-To
<87a56n3myb.fsf@iotcl.com>
On Wed, Jun 04, 2025 at 10:55:40AM +0200, Toon Claes wrote:
Show 17 quoted lines
> Patrick Steinhardt <ps@pks.im> writes:
> > diff --git a/object-store.h b/object-store.h
> > index c5890085352..a3be27d1171 100644
> > --- a/object-store.h
> > +++ b/object-store.h
> > @@ -87,7 +87,12 @@ struct packed_git;
> >  struct multi_pack_index;
> >  struct cached_object_entry;
> >  
> > -struct raw_object_store {
> > +/*
> > + * The object database encapsulates access to objects in a repository. It
> > + * manages one or more backends that store the actual objects which are
> > + * configured via alternates.
> 
> This still uses /old/ terminology. I think the "backend" should be
> called "source", and we can keep the "alternates"?

The term "source" doesn't yet exist in this commit. The next commit touches the comment, but _that_ commit still uses the old "alternate" term to talk about the sources. It's correct to say that those are configured via alternates, but the alternates do configure sources in the ODB indeed.

Patrick
Previous: Toon ClaesNext: Patrick Steinhardt
Message 4 of 23 in “object-store: carve out the object database subsystem”
  1. 00/17 object-store: carve out the object database subsystemPatrick Steinhardt, Jun 2, 2025
  2. 01/17 object-store: rename `raw_object_store` to `object_database`Patrick Steinhardt, Jun 2, 2025
  3. Toon ClaesJun 4, 2025
  4. Patrick SteinhardtJun 4, 2025
  5. 03/17 object-store: rename files to "odb.{c,h}"Patrick Steinhardt, Jun 2, 2025
  6. 02/17 object-store: rename `object_directory` to `odb_source`Patrick Steinhardt, Jun 2, 2025
  7. Toon ClaesJun 4, 2025
  8. Patrick SteinhardtJun 4, 2025
  9. 04/17 odb: introduce parent pointersPatrick Steinhardt, Jun 2, 2025
  10. 05/17 odb: get rid of `the_repository` in `find_odb()`Patrick Steinhardt, Jun 2, 2025
  11. 07/17 odb: get rid of `the_repository` in `odb_mkstemp()`Patrick Steinhardt, Jun 2, 2025
  12. 06/17 odb: get rid of `the_repository` in `assert_oid_type()`Patrick Steinhardt, Jun 2, 2025
  13. 09/17 odb: get rid of `the_repository` in `for_each()` functionsPatrick Steinhardt, Jun 2, 2025
  14. 08/17 odb: get rid of `the_repository` when handling alternatesPatrick Steinhardt, Jun 2, 2025
  15. 11/17 odb: get rid of `the_repository` when handling submodule sourcesPatrick Steinhardt, Jun 2, 2025
  16. 10/17 odb: get rid of `the_repository` when handling the primary sourcePatrick Steinhardt, Jun 2, 2025
  17. 12/17 odb: trivial refactorings to get rid of `the_repository`Patrick Steinhardt, Jun 2, 2025
  18. 13/17 odb: rename `oid_object_info()`Patrick Steinhardt, Jun 2, 2025
  19. 15/17 odb: rename `has_object()`Patrick Steinhardt, Jun 2, 2025
  20. 14/17 odb: rename `repo_read_object_file()`Patrick Steinhardt, Jun 2, 2025
  21. 17/17 odb: rename `read_object_with_reference()`Patrick Steinhardt, Jun 2, 2025
  22. 16/17 odb: rename `pretend_object_file()`Patrick Steinhardt, Jun 2, 2025
  23. Junio C HamanoJun 2, 2025

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.