Re: What's cooking in git.git (Feb 2024, #07; Tue, 20)
- From
Patrick Steinhardt <ps@pks.im>
- Date
- Feb 22, 2024, 08:25 UTC
- Message-ID
- <ZdcFDEg4Gl8YpCQi@tanuki>
- In-Reply-To
- <xmqqle7drcm5.fsf@gitster.g>
On Wed, Feb 21, 2024 at 08:44:18AM -0800, Junio C Hamano wrote:
Show 25 quoted lines
> Karthik Nayak <karthik.188@gmail.com> writes: > > >> * kn/for-all-refs (2024-02-12) 6 commits > >> - for-each-ref: add new option to include root refs > >> - ref-filter: rename 'FILTER_REFS_ALL' to 'FILTER_REFS_REGULAR' > >> - refs: introduce `refs_for_each_include_root_refs()` > >> - refs: extract out `loose_fill_ref_dir_regular_file()` > >> - refs: introduce `is_pseudoref()` and `is_headref()` > >> - Merge branch 'ps/reftable-backend' into kn/for-all-refs > >> (this branch uses ps/reftable-backend.) > >> > >> "git for-each-ref" filters its output with prefixes given from the > >> command line, but it did not honor an empty string to mean "pass > >> everything", which has been corrected. > >> > >> Will merge to 'next'? > >> source: <20240211183923.131278-1-karthik.188@gmail.com> > > > > Let me know if there's something more I could do here. > > Hmph, I do not recall what the plan for this thing was. Wasn't it > ejected from 'next' so that its UI can be rethought? Or did that > happen already and what is in 'seen' already with a new UI? > > Thanks.
This version already has the updated UI with `--include-root-refs`. There has been some discussion around whether we want to refactor the refname checking interfaces so that we do not have to introduce the two new helper functions `is_pseudoref()` and `is_headref()`. But that would result in a lot of churn, and we thus agreed that it is fine to do that in a follow up patch series.
I then forgot to have a look at the remaining patches. I can do that today.
Patrick