Re: [PATCH] config: add an includeIf.env{Exists,Bool,Is,Match}
- From
Jeff King <peff@peff.net>
- Date
- Sep 27, 2021, 20:15 UTC
- Message-ID
- <YVImeFHxY7hmb3wY@coredump.intra.peff.net>
- In-Reply-To
- <xmqqo88eq8um.fsf@gitster.g>
On Mon, Sep 27, 2021 at 09:30:41AM -0700, Junio C Hamano wrote:
Show 7 quoted lines
> >> This asserts what? FOO=" bar"? > > > > Whoops, that should have been "envIs", asserting that $FOO contains > > "bar". > > Oh, "can we check with a literal with leading whitespace?" was what > my question was about ;-)
My assumption was that nobody would really care about doing so. It is true that it's less flexible, though (and is a decision we can't easily take back later).
Show 12 quoted lines
> > As I said, I think it matters more with the infix operators, as: > > > > [includeIf "env:FOO == bar"] > > > > is more readable than: > > > > [includeIf "env:FOO==bar"] > > Sure, but at that point, we'd probably want some quoting mechanism > for the literal to be compared, e.g. > > [includeIf "env:PATH ~= \"(:|^)/usr/bin(:|$)\""]
Ick. The extra quoting of the internal double-quotes is pretty horrid to look at. Also, how does one match a double-quote in the value? \\\"?
If it were optional, that would make the common cases easy (no dq, no whitespace), and the hard ones possible.
I think this is getting into a bit of a digression, though. I'm willing to defer to Ævar, who is doing the actual work, and I don't know if he has found any of this compelling. ;)
Show 12 quoted lines
> > But I do think: > > > > [includeIf "envIs:FOO:bar"] > > > > is harder to read than even: > > > > [includeIf "envIs:FOO: bar"] > > Hmph, that's quite subjective, I am afraid. When I see the latter > in the configuration file, "do I have to have a single space before > 'bar' in the value of $FOO" would be the first question that would > come to my mind.
I think it's just the mashed-up colons that I find ugly in the first one. But I agree the latter isn't that nice either, and introduces the ambiguity you describe.
> With an understanding that our syntax is so limited that we cannot > even write '=' and need to resort to Is: instead, I'd actually find > that the former less confusing than the latter.
That I think is the most interesting question: is the "=" actually out-of-bounds? I tend to think not, based on our responses earlier in the thread.
-Peff