Re: [PATCH v2] perf: fix when running with TEST_OUTPUT_DIRECTORY
- From
Patrick Steinhardt <ps@pks.im>
- Date
- Jul 19, 2021, 10:52 UTC
- Message-ID
- <YPVZZl1FI0D8kK6C@ncase>
- In-Reply-To
- <YPU2+bG8Nge5FKWv@coredump.intra.peff.net>
On Mon, Jul 19, 2021 at 04:25:29AM -0400, Jeff King wrote:
> On Fri, Jun 18, 2021 at 03:56:08PM +0200, Patrick Steinhardt wrote:
[snip]
Show 15 quoted lines
> > diff --git a/t/perf/perf-lib.sh b/t/perf/perf-lib.sh > > index 601d9f67dd..f5ed092ee5 100644 > > --- a/t/perf/perf-lib.sh > > +++ b/t/perf/perf-lib.sh > > @@ -45,7 +45,7 @@ export TEST_DIRECTORY TRASH_DIRECTORY GIT_BUILD_DIR GIT_TEST_CMP > > MODERN_GIT=$GIT_BUILD_DIR/bin-wrappers/git > > export MODERN_GIT > > > > -perf_results_dir=$TEST_OUTPUT_DIRECTORY/test-results > > +perf_results_dir=$TEST_RESULTS_DIR > > This line puzzled me a bit. Isn't $TEST_RESULTS_DIR already defined to > be $TEST_OUTPUT_DIRECTORY/test-results? If the change here is just for > clarity / readability that's OK by me. I just want to make sure I'm not > missing something.
Yes it is, and IIRC the change was just for clarity as you assume. The logic to derive the results directory was essentially duplicated across perf-lib.sh and test-lib.sh without much of a reason, given that we always set TEST_RESULTS_DIR in test-lib.sh.
Thanks for your review!
Patrick