Re: [PATCH 0/5] *.[ch]: don't duplicate *_init() and *_INIT logic
- From
Jeff King <peff@peff.net>
- Date
- Jul 1, 2021, 16:13 UTC
- Message-ID
- <YN3pmS8q3dA3Gnd+@coredump.intra.peff.net>
- In-Reply-To
- <cover-0.5-00000000000-20210701T104855Z-avarab@gmail.com>
On Thu, Jul 01, 2021 at 12:51:24PM +0200, Ævar Arnfjörð Bjarmason wrote:
> This series implements a suggestion by Jeff King to use an idiom for > *_init() functions that avoids duplicating what we've declared in the > corresponding *_INIT macros. See > https://lore.kernel.org/git/YNytp0JAIaQih0Y4@coredump.intra.peff.net/
These all look pretty good to me. My comments are minor enough that I'll include them here rather than individual replies:
> Ævar Arnfjörð Bjarmason (5): > *.h: move some *_INIT to designated initializers
I agree with Martin's suggestion to prefer the designated initializer for STRING_LIST_INIT_NODUP. The consistency makes it easier to read.
> *.c *_init(): define in terms of corresponding *_INIT macro
Yep, nice.
> dir.[ch]: replace dir_init() with DIR_INIT
I like this. Since there is a dir_clear(), I guess somebody could argue that lacking an init function makes things less consistent/balanced. But if we don't need it, I'm happy to drop it.
> string-list.[ch]: add a string_list_init_{nodup,dup}()I like this. I agree the current "0/1" in the callers is kind of inscrutable. It does make things harder if we wanted to add more options, but that is already true due to the macro initializers.
> string-list.h users: change to use *_{nodup,dup}()Nice. IMHO you should drop the convenience wrapper here. Leaving it means we'll have to circle back later and fix up topics in flight (and it's not atomic; when we finally drop it, there may be more topics in flight then!).
If it were somehow complicated to convert callers, that might be more justified. But doing a quick conversion (which is easily detected by the compiler) in the merge commit seems like less work than having to revisit the topic later.
-Peff