git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 6/9] oid-array: provide a for-loop iterator

From
Taylor Blau <me@ttaylorr.com>
Date
Dec 4, 2020, 19:11 UTC
Message-ID
<X8qJ9yKVcGSw0bWx@nand.local>
In-Reply-To
<X8qIaOe3aT1qr+es@nand.local>
On Fri, Dec 04, 2020 at 02:05:12PM -0500, Taylor Blau wrote:
Show 15 quoted lines
> On Fri, Dec 04, 2020 at 01:53:23PM -0500, Jeff King wrote:
> > I also considered adding a full iterator type with init/next/end
> > functions (similar to what we have for hashmaps). But it ended up making
> > the callers much harder to read. This version keeps us close to a basic
> > for-loop.
>
> Yeah, I think that a full-blown iterator type is overkill for this
> purpose. Another possible approach could be a macro:
>
>   #define for_each_oid_array_unique(arr, i) \
>     for (i = 0; (i) < (array)->nr; i = oid_array_for_each_unique((arr), i))
>
> but I don't think that's making anything more clear than
> 'oid_array_for_each_unique' already is. So, I like the approach that you
> took here.

Hmm. I take part of that back; it would simplify the caller in the eighth patch, which first wants to sort the list before iterating it (which is necessary, because we look at 'i = 0' before calling oid_array_for_each_unique()).

So this could look instead like:
#define for_each_oid_array_unique(arr, i) \
    for (oid_array_sort(), i = 0; (i) < (array)->nr; i = oid_array_for_each_unique((arr), i))
Maybe a little too magical, who knows.
Previous: Taylor BlauNext: Jeff King
Message 9 of 40 in “misc commit-graph and oid-array cleanups”
  1. 0/9 misc commit-graph and oid-array cleanupsJeff King, Dec 4, 2020
  2. 1/9 oid-array.h: drop sha1 mention from header guardJeff King, Dec 4, 2020
  3. 2/9 t0064: drop sha1 mention from filenameJeff King, Dec 4, 2020
  4. 3/9 t0064: make duplicate tests more robustJeff King, Dec 4, 2020
  5. 4/9 cache.h: move hash/oid functions to hash.hJeff King, Dec 4, 2020
  6. 5/9 oid-array: make sort function publicJeff King, Dec 4, 2020
  7. 6/9 oid-array: provide a for-loop iteratorJeff King, Dec 4, 2020
  8. Taylor BlauDec 4, 2020
  9. Taylor BlauDec 4, 2020
  10. Jeff KingDec 4, 2020
  11. Jeff KingDec 4, 2020
  12. Eric SunshineDec 4, 2020
  13. Jeff KingDec 4, 2020
  14. Eric SunshineDec 4, 2020
  15. Junio C HamanoDec 4, 2020
  16. Jeff KingDec 7, 2020
  17. 7/9 commit-graph: drop count_distinct_commits() functionJeff King, Dec 4, 2020
  18. Derrick StoleeDec 4, 2020
  19. Jeff KingDec 4, 2020
  20. Derrick StoleeDec 4, 2020
  21. Jeff KingDec 4, 2020
  22. Derrick StoleeDec 4, 2020
  23. Ævar Arnfjörð BjarmasonDec 5, 2020
  24. Jeff KingDec 7, 2020
  25. 8/9 commit-graph: replace packed_oid_list with oid_arrayJeff King, Dec 4, 2020
  26. Taylor BlauDec 4, 2020
  27. 9/9 commit-graph: use size_t for array allocation and indexingJeff King, Dec 4, 2020
  28. Taylor BlauDec 4, 2020
  29. Derrick StoleeDec 4, 2020
  30. 0/9 misc commit-graph and oid-array cleanupsJeff King, Dec 7, 2020
  31. 1/9 oid-array.h: drop sha1 mention from header guardJeff King, Dec 7, 2020
  32. 2/9 t0064: drop sha1 mention from filenameJeff King, Dec 7, 2020
  33. 3/9 t0064: make duplicate tests more robustJeff King, Dec 7, 2020
  34. 4/9 cache.h: move hash/oid functions to hash.hJeff King, Dec 7, 2020
  35. 5/9 oid-array: make sort function publicJeff King, Dec 7, 2020
  36. 6/9 oid-array: provide a for-loop iteratorJeff King, Dec 7, 2020
  37. 7/9 commit-graph: drop count_distinct_commits() functionJeff King, Dec 7, 2020
  38. 8/9 commit-graph: replace packed_oid_list with oid_arrayJeff King, Dec 7, 2020
  39. 9/9 commit-graph: use size_t for array allocation and indexingJeff King, Dec 7, 2020
  40. Derrick StoleeDec 7, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.