Re: [PATCH v4 1/2] abspath: add a function to resolve paths with missing components
- From
brian m. carlson <sandals@crustytoothpaste.net>
- Date
- Dec 7, 2020, 02:11 UTC
- Message-ID
- <X82PS2RDlpXY0srv@camp.crustytoothpaste.net>
- In-Reply-To
- <CAPig+cTbtpzwcQPHUgyf=0Oe5h2_=zory2oj9oFEUrdtaRR6ng@mail.gmail.com>
On 2020-12-07 at 00:02:16, Eric Sunshine wrote:
Show 11 quoted lines
> This commit message is too barebones. As a justification, "We'd > like..." is insufficient; it doesn't help the reader understand why > this change is desirable. > > Further, the lack of explanation about the seemingly arbitrary "one or > infinite" condition confuses the issue. The first question which > popped into this reader's head was "why those two specific choices?". > What makes one missing path component special as opposed to any number > of missing components? (These questions are mostly rhetorical; I can > figure out reasonable answers, but the commit message ought to do a > better job of explaining.)
Sure, I can expand the commit message to be a little more descriptive.
> The name of the function is somewhat confusing, especially if you take > the suggestion of dropping the `many_missing` argument. Perhaps a name > such as strbuf_realpath_forgiving() would be more understandable.
Sure, I agree that's a better name. It shouldn't be surprising to anyone on the list that I am absolutely terrible at naming things, so I appreciate the suggestion.
-- brian m. carlson (he/him or they/them) Houston, Texas, US