git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/2] fetch-pack: refactor writing promisor file

From
Taylor Blau <me@ttaylorr.com>
Date
Jan 12, 2021, 19:49 UTC
Message-ID
<X/39TS5C2TNf2X6t@nand.local>
In-Reply-To
<20210112082159.2277214-2-chriscool@tuxfamily.org>
On Tue, Jan 12, 2021 at 09:21:59AM +0100, Christian Couder wrote:
> Let's replace the 2 different pieces of code that write a
> promisor file in 'builtin/repack.c' and 'fetch-pack.c'
> with a new function called 'write_promisor_file()' in
> 'pack-write.c' and 'pack.h'.

This is just great. Even though I'm sure that I have read that code in builtin/repack.c a hundred times before, I for some reason always have to remind myself what it is doing.

So, I'm very happy to see that it is being cleaned up behind a function whose name describes its behavior clearly. And, if that function can be used to remove some duplication in a sensible fashion along the way, then all the better.

  Reviewed-by: Taylor Blau <me@ttaylorr.com>

Thanks, Taylor

Previous: Christian CouderNext: Junio C Hamano
Message 3 of 7 in “fetch-pack: rename helper to create_promisor_file()”
  1. 1/2 fetch-pack: rename helper to create_promisor_file()Christian Couder, Jan 12, 2021
  2. 2/2 fetch-pack: refactor writing promisor fileChristian Couder, Jan 12, 2021
  3. Taylor BlauJan 12, 2021
  4. Junio C HamanoJan 12, 2021
  5. Junio C HamanoJan 12, 2021
  6. Jeff KingJan 13, 2021
  7. Taylor BlauJan 13, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.