git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: Isn't "dangling" a misnomer?

From
Linus Torvalds <torvalds@linux-foundation.org>
Date
Feb 26, 2007, 20:19 UTC
Message-ID
<Pine.LNX.4.64.0702261216380.12485@woody.linux-foundation.org>
In-Reply-To
<7virdolm8u.fsf@assigned-by-dhcp.cox.net>
On Mon, 26 Feb 2007, Junio C Hamano wrote:
> 
> We seem to use the word "unreachable" to refer to them.
> E.g. fsck and prune do "reachability analysis".

Well, everything that cannot be reached is "unreachable", but not everything is "dangling".

Being "dangling" is a very special case of unreachability: it's not reachable from _anything_ - including other unreachable objects.

So
	git fsck
will report about dangling objects, but
	git fsck --unreachable

will report about unreachable objects, and the result is *not* the same (dangling objects will usually be a very small subset of the unreachable ones, since in many cases *most* unreachable objects end up being pointed to by other unreachable objects, and are thus not the dangling part).

Maybe we could call the dangling objects "unreachable tips" or something. Because dangling => unreachable, but unreachable !=> dangling.

		Linus
Previous: Junio C HamanoNext: Yasushi SHOJI
Message 4 of 7 in “Isn't "dangling" a misnomer?”
  1. Mike ColemanFeb 26, 2007
  2. Johannes SchindelinFeb 26, 2007
  3. Junio C HamanoFeb 26, 2007
  4. Linus TorvaldsFeb 26, 2007
  5. Add dangling object and unreachable object in glossary.txtYasushi SHOJI, Mar 4, 2007
  6. Josef SipekMar 4, 2007
  7. Junio C HamanoMar 4, 2007

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.