Re: [PATCH 3/4] convert: Inhibit contraction of foreign $Id$ during stats.
- From
- Henrik Grubbström <grubba@roxen.com>
- Date
- Mar 15, 2010, 18:32 UTC
- Message-ID
- <Pine.GSO.4.63.1003151923290.1164@shipon.roxen.com>
- In-Reply-To
- <36ca99e91003150842q6a39a48dl2e88254fd636556d@mail.gmail.com>
On Mon, 15 Mar 2010, Bert Wesarg wrote:
Show 5 quoted lines
> 2010/3/15 Henrik Grubbström (Grubba) <grubba@grubba.org>: >> diff --git a/builtin/apply.c b/builtin/apply.c >> index 3af4ae0..25adef8 100644 >> --- a/builtin/apply.c >> +++ b/builtin/apply.c
[...]
Show 5 quoted lines
>> - convert_to_git(path, buf->buf, buf->len, buf, 0); >> + convert_to_git(path, buf->buf, buf->len, buf, 0, 0); > > So this new 0 should be ... >
[...]
Show 8 quoted lines
>> @@ -556,6 +556,11 @@ enum safe_crlf {
>> SAFE_CRLF_WARN = 2,
>> };
>>
>> +enum ident_mode {
>> + IDENT_MODE_FALSE = 0,
>
> ... this?Correct. I followed the style for the preceeding parameter (ie the other zero), which maps to enum safe_crlf SAFE_CRLF_FALSE. I agree that using the enum constants here instead of the plain zeros could perhaps be more readable, but that should be a separate patch.
-- Henrik Grubbström grubba@grubba.org Roxen Internet Software AB grubba@roxen.com