Re: [PATCH 1/3] packed_git: convert pack_local flag into generic bit mask
- From
Brandon Casey <casey@nrlssc.navy.mil>
- Date
- Nov 3, 2008, 18:24 UTC
- Message-ID
- <CU90KJ5IESAvyuMdaPcAuWOyXIdTgXenJ-InGZLiFn8@cipher.nrlssc.navy.mil>
- In-Reply-To
- <20081103161202.GJ15463@spearce.org>
Shawn O. Pearce wrote:
> drafnel@gmail.com wrote:
Show 12 quoted lines
>> diff --git a/cache.h b/cache.h
>> index b0edbf9..0cb9350 100644
>> --- a/cache.h
>> +++ b/cache.h
>> @@ -679,12 +679,15 @@ extern struct packed_git {
>> int index_version;
>> time_t mtime;
>> int pack_fd;
>> - int pack_local;
>> + unsigned int flags;
>
> Hmm, isn't this a smaller change to make?heh, well if you want to do it the "easy" way. :)
For some reason I've never used this bit field mechanism, but I agree it is more readable and simpler, and you can't argue with that.
-brandon