Re: [PATCH] builtin/mv: Get rid of the last caller of get_pathspec
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Aug 3, 2015, 22:48 UTC
- Message-ID
- <CAPig+cT_YB=HY9dBo5eRNu4qvCqCXRwwXgpxCA8YjxagP+sHfA@mail.gmail.com>
- In-Reply-To
- <1438624382-31248-1-git-send-email-sbeller@google.com>
On Mon, Aug 3, 2015 at 1:53 PM, Stefan Beller <sbeller@google.com> wrote:
Show 7 quoted lines
> `get_pathspec` is deprecated and builtin/mv is its last caller, so getting > rid of `get_pathspec` is rather easy. By getting rid of `get_pathspec`, > the documentation such as 'technical/api-setup.txt' becomes easier to read > as the reader doesn't need to bear with the additional fact that > `get_pathspec` is deprecated. > > The code in 'builtin/mv' still requires some work to make it less ugly.
Perhaps split this into two patches? One to free git-mv of get_pathspec() dependence, and the second to actually retire get_pathspec().
> Signed-off-by: Stefan Beller <sbeller@google.com>