Re: [PATCH] test-lib-functions: simplify `test_file_not_empty` failure message
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Mar 1, 2024, 22:59 UTC
- Message-ID
- <CAPig+cSt4Q0e+DioFiy7yjBgn5+gWNqQOYc0eCAgdYrZUp8VBQ@mail.gmail.com>
- In-Reply-To
- <xmqqsf194n7a.fsf@gitster.g>
On Fri, Mar 1, 2024 at 5:11 PM Junio C Hamano <gitster@pobox.com> wrote:
Show 15 quoted lines
> Eric Sunshine <ericsunshine@charter.net> writes: > > A more accurate message might be "'foo' is empty but > > should not be (or doesn't exist)", but that's unnecessarily long-winded > > and adds little information that the test author couldn't discover by > > noticing the file's absence. > > The "adds little information" version may be > > echo "'$1' is either missing or empty, but should not be" > > And avoiding "X is Y, but should be ~Y" construct, perhaps > > echo "'$1' should be a file with non-empty contents" > > would work better? I dunno.
I find "'$1' is either missing or empty, but should not be" suggestion clear and easily understood. I'll reroll with that.