Re: [RFC PATCH 1/3] config --global --edit: create a template file if needed
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Jul 25, 2014, 17:51 UTC
- Message-ID
- <CAPig+cRpcA15_FQj1Cs6M8MFUhvh0UGd2RtAf9aXLQus-mLp6g@mail.gmail.com>
- In-Reply-To
- <vpqtx65ctqm.fsf@anie.imag.fr>
On Fri, Jul 25, 2014 at 12:01 PM, Matthieu Moy <Matthieu.Moy@grenoble-inp.fr> wrote:
Show 28 quoted lines
> Eric Sunshine <sunshine@sunshineco.com> writes:
>
>>> +static char *default_user_config()
>>> +{
>>> + struct strbuf buf = STRBUF_INIT;
>>> + strbuf_addf(&buf,
>>> + _("# This is Git's user-wide configuration file.\n"
>>> + "[core]\n"
>>> + "# Please, adapt and uncomment the following lines:\n"
>>> + "# user = %s\n"
>>> + "# email = %s\n"),
>>
>> "[core]", "user =", "email =" should not be translated. Would it make
>> sense to keep these outside of _()?
>
> I would say no, as the code and the string to translate would be much
> less readable without core, user and email inline.
>
> Were you suggesting stg like
>
> _("# This is Git's user-wide configuration file.\n"
> "[%s]\n"
> "# Please, adapt and uncomment the following lines:\n"
> "# %s = %s\n"
> "# %s = %s\n"),
> "core", "name", ..., "email", ...
>
> ?That or some equivalent variation. I'm not a translator, but the above seems to convey sufficient context for a translator to understand what needs to be said, while preventing accidental translations of those strings which should not be translated.
Show 23 quoted lines
>>> + if (fd) {
>>> + char *content = default_user_config();
>>> + write_str_in_full(fd, content);
>>
>> close(fd);
>
> Indeed.
>
>>> + free(content);
>>> + }
>>> + else if (errno != EEXIST)
>>> + die_errno(_("Cannot create configuration file %s"), config_file);
>>
>> Other error messages in this file (including those just above this
>> block) begin with a lowercase letter.
>
> Applied.
>
> Thanks,
>
> --
> Matthieu Moy
> http://www-verimag.imag.fr/~moy/