Re: [PATCH 1/2] test-lib: tests skipped by GIT_SKIP_TESTS say so
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Mar 3, 2014, 23:18 UTC
- Message-ID
- <CAPig+cRnfDta9FofgH2jSdivzKvJiHwnzPZ5PoO4UTpWQLSH4w@mail.gmail.com>
On Mon, Mar 3, 2014 at 6:12 PM, Ilya Bobyr <ilya.bobir@gmail.com> wrote:
Show 14 quoted lines
> On 3/3/2014 2:59 PM, Eric Sunshine wrote: >> >> On Mon, Mar 3, 2014 at 5:24 AM, Ilya Bobyr <ilya.bobyr@gmail.com> wrote: >>> >>> We used to show "(missing )" next to tests skipped because they are >>> specified in GIT_SKIP_TESTS. Use "(matched by GIT_SKIP_TESTS)" instead. >> >> Bikeshedding: That's pretty verbose. Perhaps just say "(excluded)"? > > > The next patch adds another reason for the test to be skipped, so it seems > reasonable to say why exactly. > The patch actually makes it say "matched GIT_SKIP_TESTS". > It looks OK on the console.
Still just bikeshedding:
That new message in patch #2 says "not in GIT_TEST_ONLY", but isn't "(excluded)" also applicable to that case? Is it important to be able to distinguish between the two "excluded" reasons?
(No more bikeshedding for me.)