Re: [PATCH v4 1/3] push: further clean up fields of "struct ref"
On Wed, Jan 23, 2013 at 4:55 PM, Junio C Hamano <gitster@pobox.com> wrote:
Show 8 quoted lines
> The "nonfastforward" and "update" fields are only used while
> deciding what value to assign to the "status" locally in a single
> function. Remove them from the "struct ref".
>
> The "requires_force" field is not used to decide if the proposed
> update requires a --force option to succeed, or to record such a
> decision made elsewhere. It is used by status reporting code that
> the particular update was "forced". Rename it to "forced_udpate",