Re: [PATCH] mailinfo: resolve -Wstring-plus-int warning
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Sep 23, 2014, 08:05 UTC
- Message-ID
- <CAPig+cQE2hKU0Q+8nMRyC3V1YgKVJDkyJCAR-gBh0UoawFAoUA@mail.gmail.com>
- In-Reply-To
- <20140923075146.GA11104@peff.net>
On Tue, Sep 23, 2014 at 3:51 AM, Jeff King <peff@peff.net> wrote:
Show 22 quoted lines
> On Mon, Sep 22, 2014 at 11:26:14PM -0700, Junio C Hamano wrote: > >> On Mon, Sep 22, 2014 at 11:04 PM, Jeff King <peff@peff.net> wrote: >> > >> > I don't mind silencing this one warning (even though I find it a little >> > ridiculous). I'm slightly concerned that more brain-damage may be coming >> > our way, but we can deal with that if it ever does. >> > >> > Like Junio, I prefer keeping strlen() rather than switching to sizeof, >> > as it is less error-prone (no need for extra "-1" dance, and it won't >> > silently do the wrong thing if the array is ever converted to a >> > pointer). >> >> I actually do not mind losing the sample[] array too much. >> >> But personally, I think the way it is coded is much easier to read, >> and is much harder to get it wrong while maintaining it. So... > > I agree. I was going to suggest switching to a static const array > instead of a string literal, but retaining strlen()...but I see you > already queued that in pu. So if what is there works for Eric (I do not > have the compiler in question to test with), that seems reasonable.
What is queued in 'pu' is the same as my patch [1] minus the superfluous strlen() => sizeof() change, so it works fine for me. Thanks.
[1]: http://article.gmane.org/gmane.comp.version-control.git/257345