Re: What's cooking in git.git (Dec 2013, #01; Wed, 4)
- From
Christian Couder <christian.couder@gmail.com>
- Date
- Dec 5, 2013, 07:24 UTC
- Message-ID
- <CAP8UFD2BVYR=CcRvi3rAqNqbeBeiz+tRpEG+FKp-cfh0JOcKKQ@mail.gmail.com>
- In-Reply-To
- <xmqqiov4hz07.fsf@gitster.dls.corp.google.com>
On Thu, Dec 5, 2013 at 2:23 AM, Junio C Hamano <gitster@pobox.com> wrote:
Show 13 quoted lines
>
> * cc/starts-n-ends-with (2013-12-04) 4 commits
> - replace {pre,suf}fixcmp() with {starts,ends}_with()
> - strbuf: introduce starts_with() and ends_with()
> - builtin/remote: remove postfixcmp() and use suffixcmp() instead
> - environment: normalize use of prefixcmp() by removing " != 0"
> (this branch is used by cc/starts-n-ends-with-endgame.)
>
> Remove a few duplicate implementations of prefix/suffix comparison
> functions, and rename them to starts_with and ends_with.
>
> This conflicts with a part of cc/remote-remove-redundant-postfixcmp
> topic (I think it actually subsumes it).Yeah, it subsumes it.
Thanks, Christian.