Re: [GSoC][PATCH 2/3] clone: extract function from copy_or_link_directory
- From
Christian Couder <christian.couder@gmail.com>
- Date
- Feb 24, 2019, 08:38 UTC
- Message-ID
- <CAP8UFD0cDMr4jnjmveb10PK+xAoEEhKUgcaqbeDEktG2QuQoqQ@mail.gmail.com>
- In-Reply-To
- <20190223190309.6728-3-matheus.bernardino@usp.br>
On Sat, Feb 23, 2019 at 8:06 PM Matheus Tavares <matheus.bernardino@usp.br> wrote:
Show 13 quoted lines
> > Extract dir creation code snippet from copy_or_link_directory to its own > function named mkdir_if_missing. This change will help removing > copy_or_link_directory's explicit recursion, which will be done in a > following patch. Also makes code more readable. > > Signed-off-by: Matheus Tavares <matheus.bernardino@usp.br> > --- > Changes in v2: > - Replaced explicit reference to a following patch at patch message to > a more generic reference. > - Changed struct stat variable name to st, which is the most common > name for such variables in git's code.
Nice!