Re: [PATCH v3 00/15] reftable: drop generic `reftable_table` interface
- From
karthik nayak <karthik.188@gmail.com>
- Date
- Aug 22, 2024, 08:03 UTC
- Message-ID
- <CAOLa=ZSrL84a1=PBuhL-ddwgczi8N6H6PxsNuggN4G9mLvkORA@mail.gmail.com>
- In-Reply-To
- <cover.1724308389.git.ps@pks.im>
Patrick Steinhardt <ps@pks.im> writes:
[snip]
Show 32 quoted lines
> Range-diff against v2: > 1: 472c169b501 = 1: 472c169b501 reftable/merged: expose functions to initialize iterators > 2: bc6f1cd8c1b = 2: bc6f1cd8c1b reftable/merged: rename `reftable_new_merged_table()` > 3: 58e91ab4b34 = 3: 58e91ab4b34 reftable/merged: stop using generic tables in the merged table > 4: 6ba3fcee411 = 4: 6ba3fcee411 reftable/stack: open-code reading refs > 5: cac08a934c5 = 5: cac08a934c5 reftable/iter: drop double-checking logic > 6: 103262dc79c = 6: 103262dc79c reftable/generic: move generic iterator code into iterator interface > 7: 4011fa65d81 = 7: 4011fa65d81 reftable/dump: drop unused `compact_stack()` > 8: ceaa296bfd4 = 8: ceaa296bfd4 t/helper: inline `reftable_dump_main()` > 9: a62e4612e97 = 9: a62e4612e97 t/helper: inline `reftable_reader_print_file()` > 10: 7acfe4fecc5 ! 10: 242c179df5f t/helper: inline `reftable_stack_print_directory()` > @@ Commit message > Move `reftable_stack_print_directory()` into the "dump-reftable" helper. > This follows the same reasoning as the preceding commit. > > + Note that this requires us to remove the tests for this functionality in > + `reftable/stack_test.c`. The test does not really add much anyway, > + because all it verifies is that we do not crash or run into an error, > + and it specifically doesn't check the outputted data. Also, as the code > + is now part of the test helper, it doesn't make much sense to have a > + unit test for it in the first place. > + > Signed-off-by: Patrick Steinhardt <ps@pks.im> > > ## reftable/reftable-stack.h ## > 11: 8bd53a1a656 = 11: a05e2060996 t/helper: inline `reftable_table_print()` > 12: c50aabbb804 = 12: ee22a08e11e t/helper: inline printing of reftable records > 13: 5498395872c = 13: 0a3c619e842 t/helper: use `hash_to_hex_algop()` to print hashes > 14: 5390be75c37 = 14: 8eab399dfc6 t/helper: refactor to not use `struct reftable_table` > 15: 5aeab8ee077 = 15: b5d7b5679b5 reftable/generic: drop interface > -- > 2.46.0.164.g477ce5ccd6.dirty
This was the only change I requested in the previous version. So looks good to me now!
Thanks Karthik