Re: [PATCH v2 00/16] path: remove dependency on `the_repository`
- From
Karthik Nayak <karthik.188@gmail.com>
- Date
- Feb 7, 2025, 11:44 UTC
- Message-ID
- <CAOLa=ZSaMLXjObMACFuY+2uGvmpDcV-WdPFj4eyDukmPiC-0=g@mail.gmail.com>
- In-Reply-To
- <20250207-b4-pks-path-drop-the-repository-v2-0-13cad3c11b8a@pks.im>
Patrick Steinhardt <ps@pks.im> writes:
Show 20 quoted lines
> Hi, > > this patch series removes the dependency on `the_repository` from the > "path" subsystem. The series is structured as follows: > > - Patches 1 to 5 unifyf the interfaces that can be used to retrieve > repository paths (gitdir, commondir, workdir and submodule paths) > and adapts callers accodringly. > > - Patches 6 to 12 drop repository path functions that had an implicit > dependency on `the_repository`. > > - Patches 13 to 16 refactor "path.c"-internal code to stop depending > on `the_repository`. > > Changes in v2: > - Rename variable to `wt_gitdir` for the sake of consistency. > - Improve several commit messages. > - Link to v1: https://lore.kernel.org/r/20250206-b4-pks-path-drop-the-repository-v1-0-4e77f0313206@pks.im >
Changes look good, I had a look at the range-diff and everything looks great to me now :)
Thanks
[snip]