git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: Github Patch

From
Pablo <pabloosabaterr@gmail.com>
Date
Mar 26, 2026, 00:54 UTC
Message-ID
<CAN5EUNR2yh+OhZ-JtW-dcAFQ3k_WXyB3SXUsEb9FLReuRsMLow@mail.gmail.com>
In-Reply-To
<CAPAKoce5BeXMPtok+dni+WDTkokCAq0o4uMHGg1KZto9-UniXQ@mail.gmail.com>
Zakariyah Ali (<zakariyahali100@gmail.com>) escribió:
The mail is empty but for the attached patch.

The patch should be sent inline in the email body, not as an attachment. Please read Documentation/SubmittingPatches [1] and Documentation/MyFirstContribution [2] about how to send patches.

Now, about the patch:
> From: alibaba0010 <zakariyahali100@gmail.com>
> Signed-off-by: alibaba0010 <zakariyahali100@gmail.com>

Your email says "Zakariyah Ali" but the From and Signed-off-by says "alibaba0010. These should be consistent. See Documentation/SubmittingPatches [1].

 "It is common, but not required, to use some form of your real name.
We realize that some contributors are not comfortable doing so or
prefer to contribute under a pseudonym or preferred name and we can
accept your patch either way, as long as the name and email you use
are distinctive, identifying, and not misleading."
Show 11 quoted lines
> Replace old-style path checks using `test -f`, `test -d`,
> and `test ! -h` with dedicated test helper functions for
> improved test clarity and consistency.
>
> This modernization improves test script readability by using
> Git's dedicated test helpers: > - `test -f` → `test_path_is_file`
> - `test -d` → `test_path_is_dir`
> - `test ! -h && test -f` →
> `test_path_is_file_not_symlink`
> - `test ! -h && test -d` →
> `test_path_is_dir_not_symlink`

Try explaining why have you done this, why are these helpers better than what was before rather than clarity and consistency, what do these new helpers do to be considered valuable to refactor it.

> Found instances using: > git grep 'test -[efd]' t/ | grep 'test -[efd].*&&'

Even though it is mentioned on the microprojects to mention what have you used to find the file, because it is only one file, including the search command is not very useful. Drop it.

Given the date and that this seems a microproject I guess this is for GSoC, you should add to the subject [GSoC PATCH] and CC your possible co mentors.

I encourage you the same that it's being encourage for newcomers, read:
      https://lore.kernel.org/git/
There you'll find other microprojects similar to yours where you can learn from.
Code seems OK.

[1]: https://github.com/git/git/blob/master/Documentation/SubmittingPatches [2]: https://github.com/git/git/blob/master/Documentation/MyFirstContribution.adoc

Previous: Zakariyah AliNext: Zakariyah Ali
Message 2 of 17 in “Github Patch”
  1. Zakariyah AliMar 26, 2026
  2. PabloMar 26, 2026
  3. t2000: modernize path checks with test_path_is_* helpersZakariyah Ali, Mar 26, 2026
  4. Junio C HamanoMar 26, 2026
  5. [GSoC][PATCH v3] t2000: modernise overall structureZakariyah Ali, Mar 27, 2026
  6. Zakariyah AliMar 30, 2026
  7. Tian YuchenApr 1, 2026
  8. 1/1 t2000: modernize overall structure and path checksZakariyah Ali, Apr 5, 2026
  9. Karthik NayakApr 5, 2026
  10. Tian YuchenApr 6, 2026
  11. t2000: modernize overall structure and path checksZakariyah Ali, Apr 7, 2026
  12. Junio C HamanoApr 7, 2026
  13. Junio C HamanoApr 7, 2026
  14. t2000: consolidate second scenario into a single test blockZakariyah Ali, Apr 29, 2026
  15. Zakariyah AliMay 5, 2026
  16. Junio C HamanoMay 12, 2026
  17. Zakariyah AliMay 12, 2026

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.