Re: [PATCH v3 6/7] rebase: write better reflog messages
- From
Ramkumar Ramachandra <artagnon@gmail.com>
- Date
- Jun 24, 2013, 08:12 UTC
- Message-ID
- <CALkWK0meLtmSFNSXPxkz4dnXQ_wgNPdUbB-7TL3iqL0JOg5Qmw@mail.gmail.com>
- In-Reply-To
- <7vtxkoc557.fsf@alter.siamese.dyndns.org>
Junio C Hamano wrote:
> So you are forcing people to maintain _two_ variables, instead of > just _one_, without making anything simpler. > > What's so hard to understand why it is a wrong design?
Fine. Let's say I buy your argument about one-variable versus two-variables: how do you solve the existing problems that are solved by overriding GIT_REFLOG_ACTION that I pointed out?
> If you truly think this is "inconsequential", that unfortunately > convinces me that you cannot yet be trusted enough to give you > latitude to design interfaces that span multiple programs X-<.
*shrug* I certainly don't think one-variable versus two-variables warrants this much discussion.
I don't have anything to win or lose: I designed a solution to the problem which I think is reasonable; you don't. Fine. Show me an alternative that doesn't involve rewriting half of the rebase infrastructure in a series that fixes checkout-dash.