git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/3] prune_object_dir(): verify that path fits in the temporary buffer

From
Antoine Pelisse <apelisse@gmail.com>
Date
Dec 17, 2013, 18:56 UTC
Message-ID
<CALWbr2xmBXHaxb89665ub_cS8mFxf0C6tJnhBsdnUnX7DoCPfw@mail.gmail.com>
In-Reply-To
<1387287838-25779-3-git-send-email-mhagger@alum.mit.edu>
On Tue, Dec 17, 2013 at 2:43 PM, Michael Haggerty <mhagger@alum.mit.edu> wrote:
Show 30 quoted lines
> Dimension the buffer based on PATH_MAX rather than a magic number, and
> verify that the path fits in it before continuing.
>
> Signed-off-by: Michael Haggerty <mhagger@alum.mit.edu>
> ---
>
> I don't think that this problem is remotely exploitable, because the
> size of the string doesn't depend on inputs that can be influenced by
> a client (at least not within Git).
>
>  builtin/prune.c | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/builtin/prune.c b/builtin/prune.c
> index 6366917..ae34d04 100644
> --- a/builtin/prune.c
> +++ b/builtin/prune.c
> @@ -96,7 +96,9 @@ static void prune_object_dir(const char *path)
>  {
>         int i;
>         for (i = 0; i < 256; i++) {
> -               static char dir[4096];
> +               static char dir[PATH_MAX + 1];
> +               if (strlen(path) + 3 > PATH_MAX)
> +                       die("impossible object directory");
>                 sprintf(dir, "%s/%02x", path, i);
>                 prune_dir(i, dir);
>         }
> --
> 1.8.5.1
Obviously correct,

Thanks, Antoine,

Previous: Jeff KingNext: Michael Haggerty
Message 19 of 21 in “Fix two buffer overflows and remove a redundant var”
  1. 0/3 Fix two buffer overflows and remove a redundant varMichael Haggerty, Dec 17, 2013
  2. 1/3 prune-packed: fix a possible buffer overflowMichael Haggerty, Dec 17, 2013
  3. Duy NguyenDec 17, 2013
  4. Junio C HamanoDec 17, 2013
  5. Michael HaggertyDec 18, 2013
  6. Jeff KingDec 19, 2013
  7. Michael HaggertyDec 19, 2013
  8. Jeff KingDec 20, 2013
  9. Duy NguyenDec 19, 2013
  10. 2/3 prune_object_dir(): verify that path fits in the temporary bufferMichael Haggerty, Dec 17, 2013
  11. Junio C HamanoDec 17, 2013
  12. Jeff KingDec 17, 2013
  13. Junio C HamanoDec 18, 2013
  14. Jeff KingDec 18, 2013
  15. Junio C HamanoDec 18, 2013
  16. Jeff KingDec 18, 2013
  17. Junio C HamanoDec 18, 2013
  18. Jeff KingDec 18, 2013
  19. Antoine PelisseDec 17, 2013
  20. 3/3 cmd_repack(): remove redundant local variable "nr_packs"Michael Haggerty, Dec 17, 2013
  21. Stefan BellerDec 17, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.