git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] doc: describe Git bundle format

From
Masaya Suzuki <masayasuzuki@google.com>
Date
Jan 31, 2020, 21:49 UTC
Message-ID
<CAJB1erXnNe0yGvL+wgU9RXAA6Vyx7T2dwM9NgCmUChOtL102NQ@mail.gmail.com>
In-Reply-To
<xmqqk1579xa4.fsf@gitster-ct.c.googlers.com>
On Fri, Jan 31, 2020 at 12:38 PM Junio C Hamano <gitster@pobox.com> wrote:
Show 41 quoted lines
>
> Masaya Suzuki <masayasuzuki@google.com> writes:
>
> > The bundle format was not documented. Describe the format with ABNF and
> > explain the meaning of each part.
>
> Thanks.
>
> >
> > Signed-off-by: Masaya Suzuki <masayasuzuki@google.com>
> > ---
> >  Documentation/technical/bundle-format.txt | 40 +++++++++++++++++++++++
> >  1 file changed, 40 insertions(+)
> >  create mode 100644 Documentation/technical/bundle-format.txt
> >
> > diff --git a/Documentation/technical/bundle-format.txt b/Documentation/technical/bundle-format.txt
> > new file mode 100644
> > index 0000000000..dbb80225b5
> > --- /dev/null
> > +++ b/Documentation/technical/bundle-format.txt
> > @@ -0,0 +1,40 @@
> > += Git bundle v2 format
> > +
> > +The Git bundle format is a format that represents both refs and Git objects.
> > +
> > +== Format
> > +
> > +We will use ABNF notation to define the Git bundle format. See
> > +protocol-common.txt for the details.
> > +
> > +----
> > +bundle    = signature references pack
> > +signature = "# v2 git bundle" LF
>
> Good.  "signature" is the name used by bundle.c::create_bundle() to
> call this part.
>
> > +references   = *(prerequisite / ref) LF
>
> This allows prereq and ref can come inter-mixed, but I think we show
> all prerequisites first before refs.

Based on bundle.c::parse_bundle_header(), I infer that this can be mixed. If that's not intended, this can be changed to have prerequisites first.

Show 6 quoted lines
>
> > +prerequisite = "-" obj-id SP comment LF
> > +comment      = *CHAR
>
> Do readers know what CHAR consists of?  Anything other than NUL and
> LF?

RFC 5234 defines core rules (https://tools.ietf.org/html/rfc5234#appendix-B.1), and these CHAR etc are defined there. It should be OK to use these rules.

Show 37 quoted lines
>
> > +ref          = obj-id SP refname LF
>
> OK.
>
> "prerequisite" and "ref" are both used in bundle.c::create_bundle(),
> so calling these parts with these names is consistent with the code.
> "head" is also a good name for the latter as "git bundle list-heads"
> is the way the end-users access them from outside.
>
> > +
> > +pack         = ... ; packfile
> > +----
> > +
> > +== Semantics
> > +
> > +A Git bundle consists of three parts.
> > +
> > +*   Prerequisites: Optional list of objects that are not included in the bundle
> > +    file. A bundle can reference these prerequisite objects (or it can reference
> > +    the objects reachable from the prerequisite objects). The bundle itself
> > +    might not contain those objects.
>
> While not incorrect per-se, the above misses the more important
> points (and defers the description to a later paragraph).  It is
> better to describe what it means to have prereqs upfront.
>
> > +*   References: Mapping of ref names to objects.
> > +*   Git objects: Commit, tree, blob, and tags. These are included in the pack
> > +    format.
> > +
>
> Match the name you used to descibe the parts in the earlier ABNF
> description, so that the correspondence is clear to the readers.
> You somehow used "references" to mean both prereqs and heads, but in
> the above you are describing only "heads" under the label of
> "references".
Yes. It should match with the ABNF definition above.

I usually use "heads" to mean "references under refs/heads/*" (not sure if this is true for other people). Since a bundle can contain tags etc., using "heads" here seems confusing. With prerequisites and references split you mentioned above, I think I can make ABNF and this semantics section consistent in terms of wording.

bundle = signature *prerequisite *ref LF pack prerequisite = "-" obj-id SP comment LF comment = *CHAR reference = obj-id SP refname LF pack = ... ; packfile

The terms ("prerequisite" and "reference") are consistent with bundle.h::ref_list.

Show 9 quoted lines
>
> Perhaps something like this?
>
>     * "Prerequisites" lists the objects that are NOT included in the
>       bundle and the receiver of the bundle MUST already have, in
>       order to use the data in the bundle.  The objects stored in
>       the bundle may refer to prerequiste objects and anything
>       reachable from them and/or expressed as a delta against
>       prerequisite objects.
I want to make sure the meaning of prerequisites.
1. Are they meant for a delta base? Or are they meant to represent a
partial/shallow state?

If these prerequisites are used as a delta base, the receiver of the bundle MUST have them. If these prerequisites are the indicators of the shallowness or the partialness of the repository, the pack data would have complete data in terms of deltification (e.g. all objects in the pack file can be undeltified with just the pack file), and the bundle can be treated as a shallow-cloned/partially-cloned repository snapshot.

From what I can see from bundle.c, I think it's an indicator of a delta base, not an indicator of a shallow/partial state, but I want to make sure.

2. Do they need to be commits? Or can they be any object type?
From what I can see, it seems that they should always be commits.
3. Does the receiver have to have all reachable objects from prerequisites?

My understanding is "Yes, the receiver must have all reachable objects from prerequisites." This means that if a receiver has a shallow-cloned repository, they might not be able to proceess a bundle with prerequisites. The bundle's pack part can deltify against the objects that exist beyond the shallow depth.

Show 8 quoted lines
>
>     * "Heads" record the tips of the history graph, iow, what the
>       receiver of the bundle CAN "git fetch" from it.
>
>     * "Pack" is the pack data stream "git fetch" would send, if you
>       fetch from a repository that has the references recorded in
>       the "Heads" above into a repository that has references
>       pointing at the objects listed in "Prerequisites" above.
I'll adopt this in the next patch.
Show 13 quoted lines
>
> > +If a bundle contains prerequisites, it means the bundle has a thin pack and the
> > +bundle alone is not enough for resolving all objects. When you read such
> > +bundles, you should have those missing objects beforehand.
>
> With the above rewrite, this paragraph is unneeded.
>
> > +In the bundle format, there can be a comment following a prerequisite obj-id.
> > +This is a comment and it has no specific meaning. When you write a bundle, you
> > +can put any string here. When you read a bundle, you can ignore this part.
>
> Is it "you can"?  At least the last one should be "readers of a
> bundle MUST ignore the comment", I think.
I'll change this to MUST.
Previous: Junio C HamanoNext: Junio C Hamano
Message 4 of 16 in “doc: describe Git bundle format”
  1. doc: describe Git bundle formatMasaya Suzuki, Jan 30, 2020
  2. Johannes SchindelinJan 31, 2020
  3. Junio C HamanoJan 31, 2020
  4. Masaya SuzukiJan 31, 2020
  5. Junio C HamanoJan 31, 2020
  6. Masaya SuzukiJan 31, 2020
  7. Junio C HamanoFeb 4, 2020
  8. doc: describe Git bundle formatMasaya Suzuki, Jan 31, 2020
  9. Junio C HamanoJan 31, 2020
  10. doc: describe Git bundle formatMasaya Suzuki, Feb 7, 2020
  11. Masaya SuzukiFeb 7, 2020
  12. Junio C HamanoFeb 7, 2020
  13. Masaya SuzukiFeb 7, 2020
  14. Junio C HamanoFeb 8, 2020
  15. Masaya SuzukiFeb 12, 2020
  16. Junio C HamanoFeb 12, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.