git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: verifying syntax for optional and replaceable content in man pages

From
Stefan Beller <sbeller@google.com>
Date
May 30, 2018, 17:54 UTC
Message-ID
<CAGZ79kbdbV8r6Vr06ECOy9XXnBO_r=F-XcQU3WCCtOuCr0cfiQ@mail.gmail.com>
In-Reply-To
<alpine.LFD.2.21.1805300733440.10096@localhost.localdomain>
On Wed, May 30, 2018 at 4:39 AM, Robert P. J. Day <rpjday@crashcourse.ca> wrote:
Show 15 quoted lines
>
>   willing to submit some patches to standardize the syntax of man
> pages in terms of rendering "optional" and/or "replaceable" content,
> and it seems like "man git-config" would be a good place to start:
>
> SYNOPSIS
>        git config [<file-option>] [type] [--show-origin] [-z|--null] name [value [value_regex]]
>        git config [<file-option>] [type] --add name value
>        git config [<file-option>] [type] --replace-all name value [value_regex]
>        ...snip ...
>
>   can i assume the proper (uniform) syntax for the above would be
> (shortening lines):
>
>   ... [<type>] [--show-origin] [-z|--null] <name> [<value> [<value_regex>]]
So the difference are the angle brackets around 'name', otherwise no change?
>   ... [<type>] --add <name> <value>
all the same but angle brackets around name and value,
>   ... [<type>] --replace-all <name> <value> [<value_regex>]
same.
> and so on. is that the consensus? i wouldn't try to do it all at once,
> maybe just a page at a time to not be too disruptive.

I would think there is consensus for unifying the syntax across all man pages and put variable texts (name, path, key, value, etc) into angle brackets.

I used git-blame to find all the changes throughout history touching the first line of the synopsis (or rather: I used gitk, right click "show origin of line"), and there were no edit wars whether to use angle brackets or not; it looks like nobody cared or paid attention since the first revision of that line, which is

    git-config' [--global] [type] name [value [value_regex]]
from e0d10e1c63b ([PATCH] Rename git-repo-config to git-config., 2007-01-28)

Thanks for taking care of these! Stefan

Previous: Robert P. J. DayNext: Robert P. J. Day
Message 2 of 3 in “verifying syntax for optional and replaceable content in man pages”
  1. Robert P. J. DayMay 30, 2018
  2. Stefan BellerMay 30, 2018
  3. Robert P. J. DayMay 30, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.