git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCHv5 7/7] builtin/describe.c: describe a blob

From
Stefan Beller <sbeller@google.com>
Date
Dec 19, 2017, 19:39 UTC
Message-ID
<CAGZ79ka8PRbiHggTADNDwwO_=8rysK3sDP7tV4qerbc8C5yaSQ@mail.gmail.com>
In-Reply-To
<xmqqy3lyv7yt.fsf@gitster.mtv.corp.google.com>
On Tue, Dec 19, 2017 at 11:22 AM, Junio C Hamano <gitster@pobox.com> wrote:
> I had to squash in the following to make 'pu' pass under
> gettext-poison build.  Is this ready for 'next' otherwise?

I saw that in pu, thanks for squashing. I should have spoken up earlier confirming it.

> With the "log --find-object" thing, it may be that this no longer is
> needed, but then again we haven't done anything with the other
> Jonathan's idea to unify the --find-object thing into the --pickaxe
> framework.
I'll look into that after I finish looking at a submodule related bug.
> It seems that we tend to open and then abandon new interests without
> seeing them through completion, leaving too many loose ends untied.
> This has to stop.
I'll try to find my balance again.

When working on too few topics at the same time, sometimes I get stalled waiting for the mailing list (or internal reviewers) to respond, so I start many topics, which then overwhelm me after a while once reviews catch up.

In this specific case it was not clear what the best way is, i.e. the interest was rather broad: "Hey I have this blob sha1, how do I get more information?", which can be solved in many different ways, so I tried some of them. (Another alternative just now considered: I could have wrapped that script from stackoverflow into a new command and called it a day, though that has very poor benefits for the rest of ecosystem, an addition to an established powerful command gives more benefits IMHO)

Thanks, Stefan

Previous: Junio C HamanoNext: Junio C Hamano
Message 18 of 19 in “[PATCHv5 0/7] describe blob”
  1. Stefan BellerNov 16, 2017
  2. 1/7 t6120: fix typo in test nameStefan Beller, Nov 16, 2017
  3. 2/7 list-objects.c: factor out traverse_trees_and_blobsStefan Beller, Nov 16, 2017
  4. 3/7 revision.h: introduce blob/tree walking in order of the commitsStefan Beller, Nov 16, 2017
  5. 4/7 builtin/describe.c: rename `oid` to avoid variable shadowingStefan Beller, Nov 16, 2017
  6. 5/7 builtin/describe.c: print debug statements earlierStefan Beller, Nov 16, 2017
  7. 6/7 builtin/describe.c: factor out describe_commitStefan Beller, Nov 16, 2017
  8. 7/7 builtin/describe.c: describe a blobStefan Beller, Nov 16, 2017
  9. Junio C HamanoNov 16, 2017
  10. Stefan BellerNov 16, 2017
  11. Junio C HamanoNov 22, 2017
  12. Stefan BellerNov 22, 2017
  13. Junio C HamanoNov 24, 2017
  14. Stefan BellerNov 27, 2017
  15. Junio C HamanoNov 27, 2017
  16. Philip OakleyNov 20, 2017
  17. Junio C HamanoDec 19, 2017
  18. Stefan BellerDec 19, 2017
  19. Junio C HamanoDec 22, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.