git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: What's cooking in git.git (Aug 2015, #03; Mon, 17)

From
Stefan Beller <sbeller@google.com>
Date
Aug 17, 2015, 23:28 UTC
Message-ID
<CAGZ79ka6mz=f=g0mkgtP2955z+sRf1Sh+ArB=-ZA2ZhX27LuWw@mail.gmail.com>
In-Reply-To
<xmqqk2stbl3o.fsf@gitster.dls.corp.google.com>
On Mon, Aug 17, 2015 at 3:34 PM, Junio C Hamano <gitster@pobox.com> wrote:
Show 8 quoted lines
> * hv/submodule-config (2015-06-15) 4 commits
>  - do not die on error of parsing fetchrecursesubmodules option
>  - use new config API for worktree configurations of submodules
>  - extract functions for submodule config set and lookup
>  - implement submodule config API for lookup of .gitmodules values
>
>  The gitmodules API accessed from the C code learned to cache stuff
>  lazily.
Will reroll today as part of a larger series.
Show 9 quoted lines
> * mk/submodule-gitdir-path (2015-08-05) 2 commits
>  - path: implement common_dir handling in git_path_submodule()
>  - submodule refactor: use git_path_submodule() in add_submodule_odb()
>
>  The submodule code has been taught to work better with separate
>  work trees created via "git worktree add".
>
>  Waiting for a review.
>  ($gmane/275340).
I'll look into it.
Show 6 quoted lines
>
> * sb/remove-get-pathspec (2015-08-03) 1 commit
>  - builtin/mv: remove get_pathspec()
>
>  Expecting a reroll.
>  ($gmane/275224)

IIRC the discussion turned out to expect a full conversion of internal_copy_pathspec in builtin/mv and not just moving all the cruft there, such that we can make the deprecated function non public and update the documentation.

So I am not going to spend more time on that series, anyone is free to pick it up. So I guess dropping it for now is ok.

Show 6 quoted lines
>
>
> * sb/submodule-helper (2015-08-07) 1 commit
>  - submodule: implement `module_list` as a builtin helper
>
>  The beginning of "git submodule" rewritten in C.
This combined will be combined with hv/submodule-config
Show 65 quoted lines
>
>
> * tb/complete-rebase-i-edit-todo (2015-08-05) 1 commit
>   (merged to 'next' on 2015-08-12 at 9606c21)
>  + completion: offer '--edit-todo' during interactive rebase
>
>  The command-line completion script (in contrib/) has been updated.
>
>  Will merge to 'master'.
>
>
> * dt/untracked-subdir (2015-08-07) 2 commits
>  - DONTMERGE: wait for Duy to Ack or comment
>  - untracked-cache: fix subdirectory handling
>
>  Waiting for a review cycle to conclude.
>  ($gmane/276019).
>
>
> * jk/test-with-x (2015-08-07) 2 commits
>   (merged to 'next' on 2015-08-12 at 06576a1)
>  + test-lib: disable trace when test is not verbose
>  + test-lib: turn off "-x" tracing during chain-lint check
>
>  Running tests with the "-x" option to make them verbose had some
>  unpleasant interactions with other features of the test suite.
>
>  Will merge to 'master'.
>
>
> * ad/cygwin-wants-rename (2015-08-07) 1 commit
>  - config.mak.uname: Cygwin needs OBJECT_CREATION_USES_RENAMES
>
>  Will hold.
>  ($gmane/275680).
>
>
> * ee/clean-remove-dirs (2015-08-11) 1 commit
>   (merged to 'next' on 2015-08-12 at fc41b09)
>  + t7300-clean: require POSIXPERM for chmod 0 test
>
>  Test updates for Windows.
>
>  Will merge to 'master'.
>
>
> * jc/finalize-temp-file (2015-08-10) 1 commit
>   (merged to 'next' on 2015-08-12 at 6fe62fe)
>  + sha1_file.c: rename move_temp_to_file() to finalize_object_file()
>
>  Long overdue micro clean-up.
>
>  Will merge to 'master'.
>
>
> * jk/git-path (2015-08-10) 16 commits
>   (merged to 'next' on 2015-08-12 at 7ebe864)
>  + memoize common git-path "constant" files
>  + get_repo_path: refactor path-allocation
>  + find_hook: keep our own static buffer
>  + refs.c: remove_empty_directories can take a strbuf
>  + refs.c: avoid git_path assignment in lock_ref_sha1_basic
>  + refs.c: avoid repeated git_path calls in rename_tmp_log
>  + refs.c: simplify strbufs in reflog setup and writing
>  + path.c: drop git_path_submodule

Oops, I just wanted to add a caller to git_path_submodule. I'll also look into this series to see the alternatives. :)

Show 15 quoted lines
>  + refs.c: remove extra git_path calls from read_loose_refs
>  + remote.c: drop extraneous local variable from migrate_file
>  + prefer mkpathdup to mkpath in assignments
>  + prefer git_pathdup to git_path in some possibly-dangerous cases
>  + add_to_alternates_file: don't add duplicate entries
>  + t5700: modernize style
>  + cache.h: complete set of git_path_submodule helpers
>  + cache.h: clarify documentation for git_path, et al
>
>  git_path() and mkpath() are handy helper functions but it is easy
>  to misuse, as the callers need to be careful to keep the number of
>  active results below 4.  Their uses have been reduced.
>
>  Will merge to 'master'.
>
Previous: Junio C HamanoNext: Junio C Hamano
Message 2 of 3 in “What's cooking in git.git (Aug 2015, #03; Mon, 17)”
  1. Junio C HamanoAug 17, 2015
  2. Stefan BellerAug 17, 2015
  3. Junio C HamanoAug 17, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.