Re: What's cooking in git.git (Jun 2017, #06; Thu, 22)
- From
Stefan Beller <sbeller@google.com>
- Date
- Jun 23, 2017, 23:39 UTC
- Message-ID
- <CAGZ79kZyMUKPahTXOF7ds6zSvFKLrM2N78JKG-2+GRL5nnmuvA@mail.gmail.com>
- In-Reply-To
- <871sqajrgi.fsf@gmail.com>
On Fri, Jun 23, 2017 at 2:59 PM, Ævar Arnfjörð Bjarmason <avarab@gmail.com> wrote:
Show 38 quoted lines
>
> On Thu, Jun 22 2017, Junio C. Hamano jotted:
>
>> * sb/diff-color-move (2017-06-21) 25 commits
>> - diff: document the new --color-moved setting
>> - diff.c: add dimming to moved line detection
>> - diff.c: color moved lines differently, plain mode
>> - diff.c: color moved lines differently
>> - diff.c: buffer all output if asked to
>> - diff.c: emit_diff_symbol learns about DIFF_SYMBOL_SUMMARY
>> - diff.c: emit_diff_symbol learns about DIFF_SYMBOL_STAT_SEP
>> - diff.c: convert word diffing to use emit_diff_symbol
>> - diff.c: convert show_stats to use emit_diff_symbol
>> - diff.c: convert emit_binary_diff_body to use emit_diff_symbol
>> - submodule.c: migrate diff output to use emit_diff_symbol
>> - diff.c: emit_diff_symbol learns DIFF_SYMBOL_REWRITE_DIFF
>> - diff.c: emit_diff_symbol learns about DIFF_SYMBOL_BINARY_FILES
>> - diff.c: emit_diff_symbol learns DIFF_SYMBOL_HEADER
>> - diff.c: emit_diff_symbol learns DIFF_SYMBOL_FILEPAIR
>> - diff.c: emit_diff_symbol learns DIFF_SYMBOL_CONTEXT_INCOMPLETE
>> - diff.c: emit_diff_symbol learns DIFF_SYMBOL_WORDS{_PORCELAIN}
>> - diff.c: migrate emit_line_checked to use emit_diff_symbol
>> - diff.c: emit_diff_symbol learns DIFF_SYMBOL_NO_LF_EOF
>> - diff.c: emit_diff_symbol learns DIFF_SYMBOL_CONTEXT_FRAGINFO
>> - diff.c: emit_diff_symbol learns DIFF_SYMBOL_CONTEXT_MARKER
>> - diff.c: introduce emit_diff_symbol
>> - diff.c: factor out diff_flush_patch_all_file_pairs
>> - diff.c: move line ending check into emit_hunk_header
>> - diff.c: readability fix
>>
>> "git diff" has been taught to optionally paint new lines that are
>> the same as deleted lines elsewhere differently from genuinely new
>> lines.
>>
>> Is any more update coming?
>
> I guess here's as good a place for feedback is any, this feature's
> great, but I discovered some minor warts in it:Thanks for reporting these. :)
So: * have the boolean option as below * fix error modes in config * rewrite documentation for lazy skimming readers :)
I also consider * changing the default to zebra (instead of dimmed_zebra)
Junio wrote (when reviewing Michaels series)
Show 6 quoted lines
> This patch shows OK, but when applied to other changes in the > series, e.g. "packed_ref_store: make class into a subclass of > `ref_store`", it was somewhat irritating that all new blank lines > are shown as a copy-move of a single deleted blank line (also a > single "return refs" in an entirely new function being a copy/move > looked confusing).
* add some heuristic to omit small blobs, (empty lines, closing braces) Maybe this is can be solved by not considering anything that occurs multiple times?