Re: [PATCH 0/4] (x)diff cleanup: remove duplicate code
On Tue, Oct 24, 2017 at 11:59 AM, Stefan Beller <sbeller@google.com> wrote:
Show 19 quoted lines
> Junio wrote:
>
>> * I was hoping that the next_byte() and string_hash() thing, once
>> they are cleaned up, will eventually be shared with the xdiff/
>> code at the lower layer, which needs to do pretty much the same
>> in order to implement various whitespace ignoring options. I am
>> not sure how well the approach taken by the WIP patch meshes with
>> the needs of the lower layer.
>
> This series does exactly this; although I chose to reuse the code in
> xdiff/xutils.c instead of the new fancy next_byte/string_hash, as that
> code has seen more exercise already (hence I assume it has fewer bugs
> if any as well as its performance implications are well understood).
>
> However to do so, we need to pollute xdiff/xutils.c and include
> hashmap.h there (which also requires cache.h as that header has
> an inline function using BUG()), which I find a bit unfortunate but
> worth the trade off of using better tested code.
>
This, of course, applies on top of jk/diff-color-moved-fix.