Re: [PATCHv2] run-command: detect finished children by closed pipe rather than waitpid
- From
Stefan Beller <sbeller@google.com>
- Date
- Nov 23, 2015, 18:44 UTC
- Message-ID
- <CAGZ79kYs9+UTx__yccy6qZY+Xn4onWx3zpH51pzHPn8Hz_FMww@mail.gmail.com>
- In-Reply-To
- <5650161E.9060305@web.de>
On Fri, Nov 20, 2015 at 10:58 PM, Torsten Bögershausen <tboegi@web.de> wrote:
Show 17 quoted lines
> On 2015-11-20 22.08, Stefan Beller wrote:
> The patch looks good at first glance, one minor remark below:
>>
>> diff --git a/run-command.c b/run-command.c
>
>> @@ -1071,70 +1089,31 @@ static void pp_output(struct parallel_processes *pp)
>>
>> static int pp_collect_finished(struct parallel_processes *pp)
>> {
>> - int i = 0;
>> - pid_t pid;
>> - int wait_status, code;
>> + int i, code;
>
> code is probably "return code"?
> woud "ret_value", "res" or "rc" make that more clear ?
>The return value of invoked process, yes. "ret_value", "res" sound too much like our own future return value (by convention of naming its own return value ret_value or similar).
Instead of return code, I may settle with `exit_status`?