git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 9/9] Documentation/config: add odb.<name>.promisorRemote

From
Stefan Beller <sbeller@google.com>
Date
Aug 2, 2018, 22:55 UTC
Message-ID
<CAGZ79kYPik87zvLUPPKFzcATFUdBFcXrAkTYxpxvAQy6w1CcUw@mail.gmail.com>
In-Reply-To
<20180802061505.2983-10-chriscool@tuxfamily.org>

On Wed, Aug 1, 2018 at 11:16 PM Christian Couder <christian.couder@gmail.com> wrote:

Show 21 quoted lines
>
> From: Christian Couder <christian.couder@gmail.com>
>
> Signed-off-by: Junio C Hamano <gitster@pobox.com>
> ---
>  Documentation/config.txt | 5 +++++
>  1 file changed, 5 insertions(+)
>
> diff --git a/Documentation/config.txt b/Documentation/config.txt
> index 43b2de7b5f..2d048d47f2 100644
> --- a/Documentation/config.txt
> +++ b/Documentation/config.txt
> @@ -2513,6 +2513,11 @@ This setting can be overridden with the `GIT_NOTES_REWRITE_REF`
>  environment variable, which must be a colon separated list of refs or
>  globs.
>
> +odb.<name>.promisorRemote::
> +       The name of a promisor remote. For now promisor remotes are
> +       the only kind of remote object database (odb) that is
> +       supported.
> +

Can you explain the end goal for this? (I did not find it in the cover letter, nor do I make sense of this documentation)

So from what I understand, this series relates to partialClone, which has the remote name of the "promisor" in extensions.partialclone. That is the remote to contact for any needs w.r.t. partial clone and fetching on demand.

This key "odb.<name1>.promisorRemote = <name2>" introduces 2 new names, where do each of these two names hook in? name2 is a remote, such as "origin" from what I can tell, but which naming scheme does name1 follow here?

What makes the odb key different, in that the partial clone feature only handles objects as well?

Show 6 quoted lines
>  pack.window::
>         The size of the window used by linkgit:git-pack-objects[1] when no
>         window size is given on the command line. Defaults to 10.
> --
> 2.18.0.330.g17eb9fed90
>
Previous: Christian CouderNext: Christian Couder
Message 11 of 23 in “Introducing remote ODBs”
  1. 0/9 Introducing remote ODBsChristian Couder, Aug 2, 2018
  2. 1/9 fetch-object: make functions return an error codeChristian Couder, Aug 2, 2018
  3. 2/9 Add initial remote odb supportChristian Couder, Aug 2, 2018
  4. 3/9 remote-odb: implement remote_odb_get_direct()Christian Couder, Aug 2, 2018
  5. 4/9 remote-odb: implement remote_odb_get_many_direct()Christian Couder, Aug 2, 2018
  6. 5/9 remote-odb: add remote_odb_reinit()Christian Couder, Aug 2, 2018
  7. 6/9 Use remote_odb_get_direct() and has_remote_odb()Christian Couder, Aug 2, 2018
  8. 7/9 Use odb.origin.partialclonefilter instead of core.partialclonefilterChristian Couder, Aug 2, 2018
  9. 8/9 t0410: test fetching from many promisor remotesChristian Couder, Aug 2, 2018
  10. 9/9 Documentation/config: add odb.<name>.promisorRemoteChristian Couder, Aug 2, 2018
  11. Stefan BellerAug 2, 2018
  12. Christian CouderSep 25, 2018
  13. Junio C HamanoSep 25, 2018
  14. Jeff KingSep 26, 2018
  15. Taylor BlauSep 26, 2018
  16. Junio C HamanoSep 26, 2018
  17. Jonathan NiederOct 16, 2018
  18. Jonathan TanOct 16, 2018
  19. Junio C HamanoOct 19, 2018
  20. Jonathan NiederOct 19, 2018
  21. Junio C HamanoOct 19, 2018
  22. Christian CouderOct 31, 2018
  23. Jeff KingNov 1, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.