Re: [PATCH 22/32] checkout: support checking out into a new working directory
- From
Duy Nguyen <pclouds@gmail.com>
- Date
- Sep 8, 2014, 10:52 UTC
- Message-ID
- <CACsJy8DxUguPohjYGTgnHjBc=0mqn20c67pTBN34VRz7oCjyGA@mail.gmail.com>
- In-Reply-To
- <xmqqfvga2ai9.fsf@gitster.dls.corp.google.com>
On Wed, Sep 3, 2014 at 12:33 AM, Junio C Hamano <gitster@pobox.com> wrote:
Show 21 quoted lines
> Marc Branchaud <marcnarc@xiplink.com> writes: > >> On 14-09-02 08:27 AM, Duy Nguyen wrote: >>> After reading this "multiple checkout mode" in git-checkout.txt, I'm >>> tempted to rewrite it like this. I think the example makes it clearer >>> what I mean. If nobody has any comments, I'm going to send v2 with >>> this (and other comments collected so far) >> >> Overall I think focusing on the word "checkout" for this feature makes the >> documentation confusing. It's also not a "mode" but just another git >> feature. Since this is all about multiple working directories (the phrase is >> actually "working tree" in the existing docs) we should just stick to that >> rather than introduce new terminology. >> >> Finally, a bit of bikeshedding, but I think "$GIT_DIR/repos" is also an >> unfortunate choice and that "$GIT_DIR/worktrees" would be better. > > I tried to stay away from bikeshedding, but a good phrasing is > important. I think $GIT_DIR/worktrees captures what they are trying > to represent better in that they are not storing repository > information, but they are about storing per-worktree state.
While we're changing the terms, I wonder if "primary working directory" and "secondary working directories" are better than "main checkout" and "linked checkout".
-- Duy