git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: What's cooking in git.git (Jun 2014, #04; Tue, 17)

From
Duy Nguyen <pclouds@gmail.com>
Date
Jun 19, 2014, 10:06 UTC
Message-ID
<CACsJy8CXbbNEFigjibd-W3V3RaXOzsptMkufMybYCKPFAHM6UA@mail.gmail.com>
In-Reply-To
<xmqqfvj2jfkg.fsf@gitster.dls.corp.google.com>
On Thu, Jun 19, 2014 at 12:25 AM, Junio C Hamano <gitster@pobox.com> wrote:
Show 34 quoted lines
> [Stalled]
> * nd/multiple-work-trees (2014-03-25) 28 commits
>  - count-objects: report unused files in $GIT_DIR/repos/...
>  - gc: support prune --repos
>  - gc: style change -- no SP before closing bracket
>  - prune: strategies for linked checkouts
>  - checkout: detach if the branch is already checked out elsewhere
>  - checkout: clean up half-prepared directories in --to mode
>  - checkout: support checking out into a new working directory
>  - use new wrapper write_file() for simple file writing
>  - wrapper.c: wrapper to open a file, fprintf then close
>  - setup.c: support multi-checkout repo setup
>  - setup.c: detect $GIT_COMMON_DIR check_repository_format_gently()
>  - setup.c: convert check_repository_format_gently to use strbuf
>  - setup.c: detect $GIT_COMMON_DIR in is_git_directory()
>  - setup.c: convert is_git_directory() to use strbuf
>  - git-stash: avoid hardcoding $GIT_DIR/logs/....
>  - *.sh: avoid hardcoding $GIT_DIR/hooks/...
>  - git-sh-setup.sh: use rev-parse --git-path to get $GIT_DIR/objects
>  - $GIT_COMMON_DIR: a new environment variable
>  - commit: use SEQ_DIR instead of hardcoding "sequencer"
>  - fast-import: use git_path() for accessing .git dir instead of get_git_dir()
>  - reflog: avoid constructing .lock path with git_path
>  - *.sh: respect $GIT_INDEX_FILE
>  - git_path(): be aware of file relocation in $GIT_DIR
>  - path.c: group git_path(), git_pathdup() and strbuf_git_path() together
>  - path.c: rename vsnpath() to do_git_path()
>  - git_snpath(): retire and replace with strbuf_git_path()
>  - path.c: make get_pathname() call sites return const char *
>  - path.c: make get_pathname() return strbuf instead of static buffer
>
>  A replacement for contrib/workdir/git-new-workdir that does not
>  rely on symbolic links and make sharing of objects and refs safer
>  by making the borrowee and borrowers aware of each other.

Anything I can do to get this going again? The only thing I just found (and have not fixed) is, I think $GIT_DIR/info/excludes and $GIT_DIR/info/sparse-checkout should be per-worktree, not shared.

-- 
Duy
Previous: Junio C HamanoNext: Junio C Hamano
Message 2 of 3 in “What's cooking in git.git (Jun 2014, #04; Tue, 17)”
  1. Junio C HamanoJun 18, 2014
  2. Duy NguyenJun 19, 2014
  3. Junio C HamanoJun 19, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.