Re: What's cooking in git.git (Mar 2014, #03; Fri, 14)
- From
Duy Nguyen <pclouds@gmail.com>
- Date
- Mar 15, 2014, 12:34 UTC
- Message-ID
- <CACsJy8B3OPe1B4J8-4v_Oq0ZJpWfms8SmrrbfvYHzJ3WpE8P6w@mail.gmail.com>
- In-Reply-To
- <xmqqlhwcfn4a.fsf@gitster.dls.corp.google.com>
On Sat, Mar 15, 2014 at 5:09 AM, Junio C Hamano <gitster@pobox.com> wrote:
Show 31 quoted lines
> * nd/multiple-work-trees (2014-03-06) 28 commits > - FIXUP: minimum compilation fix > - count-objects: report unused files in $GIT_DIR/repos/... > - gc: support prune --repos > - gc: style change -- no SP before closing bracket > - prune: strategies for linked checkouts > - checkout: detach if the branch is already checked out elsewhere > - checkout: clean up half-prepared directories in --to mode > - checkout: support checking out into a new working directory > - use new wrapper write_file() for simple file writing > - wrapper.c: wrapper to open a file, fprintf then close > - setup.c: support multi-checkout repo setup > - setup.c: detect $GIT_COMMON_DIR check_repository_format_gently() > - setup.c: convert check_repository_format_gently to use strbuf > - setup.c: detect $GIT_COMMON_DIR in is_git_directory() > - setup.c: convert is_git_directory() to use strbuf > - git-stash: avoid hardcoding $GIT_DIR/logs/.... > - *.sh: avoid hardcoding $GIT_DIR/hooks/... > - git-sh-setup.sh: use rev-parse --git-path to get $GIT_DIR/objects > - Add new environment variable $GIT_COMMON_DIR > - commit: use SEQ_DIR instead of hardcoding "sequencer" > - fast-import: use git_path() for accessing .git dir instead of get_git_dir() > - reflog: avoid constructing .lock path with git_path > - *.sh: respect $GIT_INDEX_FILE > - Make git_path() aware of file relocation in $GIT_DIR > - path.c: group git_path(), git_pathdup() and strbuf_git_path() together > - path.c: rename vsnpath() to do_git_path() > - Convert git_snpath() to strbuf_git_path() > - path.c: make get_pathname() return strbuf instead of static buffer > > The series needs a serious review.
There are two minor fixes [1] [2] on top of v5, but I'm not going to send v6 again unless I see more substantial changes. Just give me a signal or something before you merge to next so I have a chance to fix them if v6 never comes.
[1] http://article.gmane.org/gmane.comp.version-control.git/243693 [2] http://article.gmane.org/gmane.comp.version-control.git/243692
-- Duy