Re: [PATCH 03/19] t5800: document some non-functional parts of remote helpers
- From
Sverre Rabbelier <srabbelier@gmail.com>
- Date
- Jun 8, 2011, 21:13 UTC
- Message-ID
- <BANLkTi=-roQ5DH6RQ75+EwfDr9LutU0jrw@mail.gmail.com>
- In-Reply-To
- <20110608192850.GF27715@elie>
Heya,
On Wed, Jun 8, 2011 at 21:28, Jonathan Nieder <jrnieder@gmail.com> wrote:
Show 11 quoted lines
>> +test_expect_failure PYTHON_24 'fetch new branch' ' > > Side note: this repeated PYTHON_24 implementation detail as a > prerequisite feels wrong. Would it make sense to do something like > > if test_have_prereq PYTHON_24 > then > test_set_prereq REMOTE_TESTGIT > fi > > at the start and use that?
I don't know, it already says:
if test_have_prereq PYTHON && "$PYTHON_PATH" -c '
import sys
if sys.hexversion < 0x02040000:
sys.exit(1)
'
then
# Requires Python 2.4 or newer
test_set_prereq PYTHON_24
fiAt the start. Are you suggesting to rename PYTHON_24 to REMOTE_TESTGIT?
> It would also be interesting to test tag pushes and pushes by object > name.
I was going to test this, but it seems there's a problem with my series. Peff, if you want to look into it, (if not I'll try to look at it tomorrow) it's up at my github fork [0].
ok 12 - push when remote has extra refs
expecting success: (cd clone && git checkout -b new-name && echo content >>file && git commit -a -m seven && git push origin new-name ) && compare_refs clone HEAD server refs/heads/new-name
Switched to a new branch 'new-name' [new-name f29f436] seven Author: A U Thor <author@example.com> 1 files changed, 1 insertions(+), 0 deletions(-) Unpacking objects: 100% (3/3), done. To testgit::file:///home/sverre/code/git/t/trash directory.t5800-remote-helpers/server * [new branch] master error: Trying to write ref refs/remotes/origin/master with nonexistant object 0000000000000000000000000000000000000000 error: Cannot update the ref 'refs/remotes/origin/master'.
[0] https://github.com/SRabbelier/git/commits/remote-helpers
-- Cheers, Sverre Rabbelier