Re: [PATCH/RFC] init, clone: support --real-git-dir for .git file
2011/3/4 Miles Bader <miles@gnu.org>:
Show 13 quoted lines
> Junio C Hamano <gitster@pobox.com> writes:
>>> Instead of creating the repository at $GIT_DIR, --real-git-dir will
>>> tell git to put the repository there, then make $GIT_DIR a .git file
>>> that points to --real-git-dir.
>>
>> Just like you, I am also bad at naming things, so I cannot offhand suggest
>> a better name, even though I _know_ --real-git-dir sounds horrible.
>
> --separate-git-dir ?
>
> [Terms like "separate source dir" and "separate build dir" seems to be
> common when talking about build systems, and it seems a somewhat
> similar situation -- separation of usually co-located information.]
--
Duy