git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 02/38] rename_ref_available(): add docstring

From
Michael Haggerty <mhagger@alum.mit.edu>
Date
Sep 7, 2016, 04:32 UTC
Message-ID
<8a13500c-55a0-a069-4b69-a651c218ded5@alum.mit.edu>
In-Reply-To
<236a95a0-59d4-3788-9104-5ca299119e66@gmail.com>
On 09/06/2016 04:25 PM, Jakub Narębski wrote:
Show 16 quoted lines
> W dniu 04.09.2016 o 18:08, Michael Haggerty pisze:
> 
>> +/*
>> + * Check whether an attempt to rename old_refname to new_refname would
>> + * cause a D/F conflict with any existing reference (other than
>> + * possibly old_refname). If there would be a conflict, emit an error
>> + * message and return false; otherwise, return true.
>> + *
>> + * Note that this function is not safe against all races with other
>> + * processes (though rename_ref() catches some races that might get by
>> + * this check).
>> + */
>> +int rename_ref_available(const char *old_refname, const char *new_refname);
> 
> Just a sidenote: does Git have a naming convention for query functions
> returning a boolean, for example using is_* as a prefix?

I've never heard of an official convention like that, and don't see it documented anywhere. But there are a lot of functions (and variables) whose names start with `is_`, and it seems like a reasonable idea.

> That is, shouldn't it be
> 
>   int is_rename_ref_available(const char *old_refname, const char *new_refname);
I agree, that would be a better name.

But that naming change is orthogonal to this patch series, which only adds a docstring to the function. I don't think it's worth rerolling this 38-patch series to add it. So I suggest that we keep your idea in mind for the next time this code is touched (or feel free to submit a patch yourself, preferably on top of this patch series to avoid conflicts).

Thanks, Michael

Previous: Jakub NarębskiNext: Michael Haggerty
Message 5 of 49 in “Virtualization of the refs API”
  1. 00/38 Virtualization of the refs APIMichael Haggerty, Sep 4, 2016
  2. 06/38 add_packed_ref(): add a files_ref_store argumentMichael Haggerty, Sep 4, 2016
  3. 02/38 rename_ref_available(): add docstringMichael Haggerty, Sep 4, 2016
  4. Jakub NarębskiSep 6, 2016
  5. Michael HaggertySep 7, 2016
  6. 01/38 resolve_gitlink_ref(): eliminate temporary variableMichael Haggerty, Sep 4, 2016
  7. 04/38 refs: add a backend method structureMichael Haggerty, Sep 4, 2016
  8. David TurnerSep 4, 2016
  9. 07/38 get_packed_ref(): add a files_ref_store argumentMichael Haggerty, Sep 4, 2016
  10. 14/38 read_raw_ref(): take a (struct ref_store *) argumentMichael Haggerty, Sep 4, 2016
  11. 10/38 refs: add a transaction_commit() methodMichael Haggerty, Sep 4, 2016
  12. 03/38 refs: rename struct ref_cache to files_ref_storeMichael Haggerty, Sep 4, 2016
  13. 16/38 resolve_gitlink_ref(): implement using resolve_ref_recursively()Michael Haggerty, Sep 4, 2016
  14. 18/38 resolve_gitlink_ref(): rename path parameter to submoduleMichael Haggerty, Sep 4, 2016
  15. 08/38 resolve_missing_loose_ref(): add a files_ref_store argumentMichael Haggerty, Sep 4, 2016
  16. 31/38 refs: add method iterator_beginMichael Haggerty, Sep 4, 2016
  17. 35/38 refs: add methods to init refs dbMichael Haggerty, Sep 4, 2016
  18. 38/38 refs: implement iteration over only per-worktree refsMichael Haggerty, Sep 4, 2016
  19. David TurnerSep 8, 2016
  20. 32/38 refs: add methods for reflogMichael Haggerty, Sep 4, 2016
  21. 33/38 refs: add method for initial ref transaction commitMichael Haggerty, Sep 4, 2016
  22. 29/38 split_symref_update(): add a files_ref_store argumentMichael Haggerty, Sep 4, 2016
  23. 37/38 refs: make lock genericMichael Haggerty, Sep 4, 2016
  24. 30/38 files_ref_iterator_begin(): take a ref_store argumentMichael Haggerty, Sep 4, 2016
  25. 22/38 refs: make create_symref() virtualMichael Haggerty, Sep 4, 2016
  26. 15/38 resolve_ref_recursively(): new functionMichael Haggerty, Sep 4, 2016
  27. 27/38 lock_ref_for_update(): add a files_ref_store argumentMichael Haggerty, Sep 4, 2016
  28. 36/38 refs: add method to rename refsMichael Haggerty, Sep 4, 2016
  29. 26/38 commit_ref_update(): add a files_ref_store argumentMichael Haggerty, Sep 4, 2016
  30. 28/38 lock_ref_sha1_basic(): add a files_ref_store argumentMichael Haggerty, Sep 4, 2016
  31. 34/38 refs: make delete_refs() virtualMichael Haggerty, Sep 4, 2016
  32. 12/38 resolve_packed_ref(): rename function from resolve_missing_loose_ref()Michael Haggerty, Sep 4, 2016
  33. 13/38 resolve_gitlink_packed_ref(): remove functionMichael Haggerty, Sep 4, 2016
  34. 19/38 refs: make read_raw_ref() virtualMichael Haggerty, Sep 4, 2016
  35. 25/38 lock_raw_ref(): add a files_ref_store argumentMichael Haggerty, Sep 4, 2016
  36. 11/38 refs: reorder definitionsMichael Haggerty, Sep 4, 2016
  37. 17/38 resolve_gitlink_ref(): avoid memory allocation in many casesMichael Haggerty, Sep 4, 2016
  38. 24/38 repack_without_refs(): add a files_ref_store argumentMichael Haggerty, Sep 4, 2016
  39. 20/38 refs: make verify_refname_available() virtualMichael Haggerty, Sep 4, 2016
  40. 05/38 refs: create a base class "ref_store" for files_ref_storeMichael Haggerty, Sep 4, 2016
  41. David TurnerSep 4, 2016
  42. Michael HaggertySep 5, 2016
  43. Stefan BellerSep 5, 2016
  44. David TurnerSep 5, 2016
  45. 09/38 {lock,commit,rollback}_packed_refs(): add files_ref_store argumentsMichael Haggerty, Sep 4, 2016
  46. 21/38 refs: make pack_refs() virtualMichael Haggerty, Sep 4, 2016
  47. 23/38 refs: make peel_ref() virtualMichael Haggerty, Sep 4, 2016
  48. Junio C HamanoSep 7, 2016
  49. Michael HaggertySep 8, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.