Re: [PATCH 1/3] remote: add a test for extra arguments, according to docs
- From
Thomas Rast <trast@inf.ethz.ch>
- Date
- Apr 25, 2013, 07:23 UTC
- Message-ID
- <87obd3cbux.fsf@linux-k42r.v.cablecom.net>
- In-Reply-To
- <7vhaiva9u5.fsf@alter.siamese.dyndns.org>
Junio C Hamano <gitster@pobox.com> writes:
Show 24 quoted lines
> Thomas Rast <trast@inf.ethz.ch> writes:
>
>> +test_extra_arg () {
>> + expect="success"
>> + if test "z$1" = "z-f"; then
>> + expect=failure
>> + shift
>> + fi
>> + test_expect_$expect "extra args: $*" "
>> + test_must_fail git remote $* bogus_extra_arg 2>actual &&
>> + grep '^usage:' actual
>> + "
>> +}
>> +
>> +test_extra_arg -f add nick url
>> +test_extra_arg rename origin newname
>
> Perhaps just a taste in readability thing, but I would prefer to see
> them more like
>
> test_extra_arg_expect failure add nick url
> test_extra_arg_expect success rename origin newname
>
> than misunderstanding-inviting "-f" that often stands for "--force".Hmm. I had that at first, but then the final cleanup would have had to touch all tests to remove the optional argument, making it noisy.
Anyway, it's probably all a bit over-engineered for only one effective code change ;-)
--
Thomas Rast
trast@{inf,student}.ethz.ch