git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 2/2] send-email: Support separate Reply-To address

From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
Date
Jan 17, 2018, 22:06 UTC
Message-ID
<87fu74i1hn.fsf@evledraar.gmail.com>
In-Reply-To
<20180117180801.31049-2-chrissicool@gmail.com>
On Wed, Jan 17 2018, Christian Ludwig jotted:
Show 5 quoted lines
> +if (defined $reply_to) {
> +	$reply_to =~ s/^\s+|\s+$//g;
> +	($reply_to) = expand_aliases($reply_to);
> +	$reply_to = sanitize_address($reply_to);
> +}

Just a note to other reviewers: I found it odd to call a function with one argument and then enforce list context, but I see expand_aliases() expects to be called that way, and this is copied from a previous pattern earlier in the file.

(As an aside, that code looks a bit odd, but then I see 302e04ea4d ("send-email: detect cycles in alias expansion", 2009-07-23) )

Looks good to me.
Previous: Junio C HamanoNext: Martin Ågren
Message 4 of 6 in “send-email: Rename variable for clarity”
  1. 1/2 send-email: Rename variable for clarityChristian Ludwig, Jan 17, 2018
  2. 2/2 send-email: Support separate Reply-To addressChristian Ludwig, Jan 17, 2018
  3. Junio C HamanoJan 17, 2018
  4. Ævar Arnfjörð BjarmasonJan 17, 2018
  5. Martin ÅgrenJan 18, 2018
  6. Junio C HamanoJan 17, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.