git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH/RFC v3 4/9] unlink_entry(): introduce schedule_dir_for_removal()

From
KBKjetil Barvik <barvik@broadpark.no>
Date
Feb 4, 2009, 21:32 UTC
Message-ID
<86myd1zy4x.fsf@broadpark.no>
In-Reply-To
<7vfxitorb7.fsf@gitster.siamese.dyndns.org>
Junio C Hamano <gitster@pobox.com> writes:
Show 14 quoted lines
> Kjetil Barvik <barvik@broadpark.no> writes:
>
>> Since the unlink_entry() function is called with alphabetically sorted
>> names, this new function end up being very effective to avoid
>> unnecessary calls to rmdir().  In some cases over 95% of all calls to
>> rmdir() is removed with this patch.
>
> I first feared that this will badly break D/F conflicting cases where we
> remove a file D/F that is the last remaining file in directory D and rely
> on the successful removal of the directory to create a file D, but the
> check_updates() function already is structured to allow this late removal
> easily.
>
> I think the patch is sensible modulo minor nits.
  Yes, if the 2 for-loop's inside check_updates() is rewritten into 1
  for-loop, then you could end up with such a conflict.  Should I add a
  comment about this inside check_updates()?
>  * The new global path_buf/path_len in unpack-trees.c are named too
>    generic.  It is not just a buffer anybody can use for anything, but
>    is used to keep track for a specific purpose of doing something, so
>    please name them after that something.
   Already done in v3 (this version), since the functions
   schedule_dir_for_removal() and remove_scheduled_dirs() is now
   implemented in the symlinks.c file, where I have made the following:
static struct removal_def {
	char path[PATH_MAX];
	int len;
} removal;
>  * "#define ALL_DIRS 0" is useless, given the way how the parameter to
>    do_remove_scheduled_dirs() is named;
  Ok, I can do a rebase of this patch (4/9) and resend the patches.
  -- kjetil
Previous: Junio C HamanoNext: Kjetil Barvik
Message 8 of 23 in “git checkout: more cleanups, optimisation, less lstat() calls”
  1. 0/9 git checkout: more cleanups, optimisation, less lstat() callsKjetil Barvik, Feb 4, 2009
  2. 1/9 lstat_cache(): small cleanup and optimisationKjetil Barvik, Feb 4, 2009
  3. 2/9 lstat_cache(): generalise longest_match_lstat_cache()Kjetil Barvik, Feb 4, 2009
  4. 3/9 lstat_cache(): swap func(length, string) into func(string, length)Kjetil Barvik, Feb 4, 2009
  5. 4/9 unlink_entry(): introduce schedule_dir_for_removal()Kjetil Barvik, Feb 4, 2009
  6. Junio C HamanoFeb 4, 2009
  7. Junio C HamanoFeb 4, 2009
  8. Kjetil BarvikFeb 4, 2009
  9. 5/9 create_directories(): remove some memcpy() and strchr() callsKjetil Barvik, Feb 4, 2009
  10. 6/9 write_entry(): cleanup of some duplicated codeKjetil Barvik, Feb 4, 2009
  11. 7/9 write_entry(): use fstat() instead of lstat() when file is openKjetil Barvik, Feb 4, 2009
  12. Johannes SixtFeb 4, 2009
  13. Junio C HamanoFeb 4, 2009
  14. Kjetil BarvikFeb 4, 2009
  15. Junio C HamanoFeb 4, 2009
  16. Johannes SixtFeb 5, 2009
  17. Johannes SchindelinFeb 5, 2009
  18. Junio C HamanoFeb 5, 2009
  19. Kjetil BarvikFeb 6, 2009
  20. Johannes SchindelinFeb 6, 2009
  21. Kjetil BarvikFeb 14, 2009
  22. 8/9 show_patch_diff(): remove a call to fstat()Kjetil Barvik, Feb 4, 2009
  23. 9/9 lstat_cache(): print a warning if doing ping-pong between cache typesKjetil Barvik, Feb 4, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.