git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3 1/3] repo-settings: create core.featureAdoptionRate setting

From
Jakub Narebski <jnareb@gmail.com>
Date
Jul 4, 2019, 22:47 UTC
Message-ID
<86ftnl1kod.fsf@gmail.com>
In-Reply-To
<CACsJy8Cwxov9VWq_MpeWstGtMB-rTy6LYyFj_PF9oSP0kqcDXQ@mail.gmail.com>
Duy Nguyen <pclouds@gmail.com> writes:
Show 19 quoted lines
> On Mon, Jul 1, 2019 at 10:32 PM Derrick Stolee via GitGitGadget
> <gitgitgadget@gmail.com> wrote:
>> @@ -601,3 +602,22 @@ core.abbrev::
>>         in your repository, which hopefully is enough for
>>         abbreviated object names to stay unique for some time.
>>         The minimum length is 4.
>> +
>> +core.featureAdoptionRate::
>> +       Set an integer value on a scale from 0 to 10 describing your
>> +       desire to adopt new performance features. Defaults to 0. As
>> +       the value increases, features are enabled by changing the
>> +       default values of other config settings. If a config variable
>> +       is specified explicitly, the explicit value will override these
>> +       defaults:
>
> This is because I'd like to keep core.* from growing too big (it's
> already big), hard to read, search and maintain. Perhaps this should
> belong to a separate group? Something like tuning.something or
> defaults.something.

I'm not sure if I consider core.* too big. Well, there are 55 or more entries in this namespace.

Show 9 quoted lines
>> +If the value is at least 3, then the following defaults are modified.
>> +These represent relatively new features that have existed for multiple
>> +major releases, and may present performance benefits. These benefits
>> +depend on the amount and kind of data in your repo and how you use it.
>
> Then instead of numeric values, maybe the user should write some sort
> description about the repo and we optimize for that, similar to gcc
> -Os optimized for size, -Ofast for compiler speed (-O<n> is all about
> execution speed).
I also do not like those magic numbers.
Show 6 quoted lines
>
> We could write, for example, tuning.commitHistory = {small, medium,
> large} and tuning.worktree = {small, large, medium} and maybe
> tuning.refSize and use that to optimize. We can still have different
> optimization levels (probably just "none", "recommended" vs
> "aggressive" where agressive enables most new stuff),

I think we have three different things that are currently conflated in one config variable and one value.

First is what we want to optimize for; is it on-disk repository size, command performance / execution speed, or maybe convenient information.

Second is what type of repository we are dealing with. Is there a problem with long history, large number of files in checkout, large and/or binary files, or all together? The original `core.size=large` (or proposed core.repositorySize) was all about this issue. Another issue that might be important is that if it is leaf developer repository, or is it maintainer repository, etc. (which affects for example how the push looks like).

Third is what tradeoffs we are willing to accept to get required performance. Are we willing to use additional stable optional features; are we willing to use new experimental optional features; are we willing; are we willing to sacrifice convenience (ahead/behind information in status, information bout forced updates in push output, etc.) for performance? This what current proposal is about.

It may not nnned to be a separate confi variable for a separate aspect; it may be enough to have value that is space-separated list, or something like that.

Best, -- Jakub Narębski

Previous: Ævar Arnfjörð BjarmasonNext: Derrick Stolee via GitGitGadget
Message 40 of 48 in “[RFC] Create 'core.size=large' setting to update config defaults”
  1. 00/11 [RFC] Create 'core.size=large' setting to update config defaultsDerrick Stolee via GitGitGadget, Jun 3, 2019
  2. 01/11 repo-settings: create repo.size=large settingDerrick Stolee via GitGitGadget, Jun 3, 2019
  3. Jeff HostetlerJun 3, 2019
  4. 02/11 repo-settings: use index.version=4 by defaultDerrick Stolee via GitGitGadget, Jun 3, 2019
  5. 05/11 status: add warning when a/b calculation takes too long for long/normal formatJeff Hostetler via GitGitGadget, Jun 3, 2019
  6. 09/11 fetch: warn about forced updates after branch listDerrick Stolee via GitGitGadget, Jun 3, 2019
  7. 07/11 repo-settings: status.aheadBehind=falseDerrick Stolee via GitGitGadget, Jun 3, 2019
  8. 11/11 repo-settings: fetch.showForcedUpdates=falseDerrick Stolee via GitGitGadget, Jun 3, 2019
  9. 10/11 pull: add --[no-]show-forced-updates passthrough to fetchDerrick Stolee via GitGitGadget, Jun 3, 2019
  10. 08/11 fetch: add --[no-]show-forced-updates argumentDerrick Stolee via GitGitGadget, Jun 3, 2019
  11. 03/11 repo-settings: pack.useSparse=trueDerrick Stolee via GitGitGadget, Jun 3, 2019
  12. 06/11 status: ignore status.aheadbehind in porcelain formatsJeff Hostetler via GitGitGadget, Jun 3, 2019
  13. 04/11 status: add status.aheadbehind settingJeff Hostetler via GitGitGadget, Jun 3, 2019
  14. Derrick StoleeJun 3, 2019
  15. Johannes SchindelinJun 4, 2019
  16. Derrick StoleeJun 4, 2019
  17. Junio C HamanoJun 5, 2019
  18. Derrick StoleeJun 6, 2019
  19. Junio C HamanoJun 6, 2019
  20. 0/3 [RFC] Create 'core.featureAdoptionRate' setting to update config defaultsDerrick Stolee via GitGitGadget, Jun 19, 2019
  21. 2/3 repo-settings: use index.version=4 by defaultDerrick Stolee via GitGitGadget, Jun 19, 2019
  22. 3/3 repo-settings: pack.useSparse=trueDerrick Stolee via GitGitGadget, Jun 19, 2019
  23. 1/3 repo-settings: create core.featureAdoptionRate settingDerrick Stolee via GitGitGadget, Jun 19, 2019
  24. Junio C HamanoJun 28, 2019
  25. Derrick StoleeJun 28, 2019
  26. Junio C HamanoJun 28, 2019
  27. Derrick StoleeJun 29, 2019
  28. Carlo ArenasJun 30, 2019
  29. Derrick StoleeJul 1, 2019
  30. Ævar Arnfjörð BjarmasonJul 2, 2019
  31. Duy NguyenJul 2, 2019
  32. Derrick StoleeJul 2, 2019
  33. Junio C HamanoJul 2, 2019
  34. 0/3 [RFC] Create 'core.featureAdoptionRate' setting to update config defaultsDerrick Stolee via GitGitGadget, Jul 1, 2019
  35. 2/3 repo-settings: use index.version=4 by defaultDerrick Stolee via GitGitGadget, Jul 1, 2019
  36. 1/3 repo-settings: create core.featureAdoptionRate settingDerrick Stolee via GitGitGadget, Jul 1, 2019
  37. Carlo ArenasJul 1, 2019
  38. Duy NguyenJul 2, 2019
  39. Ævar Arnfjörð BjarmasonJul 2, 2019
  40. Jakub NarebskiJul 4, 2019
  41. 3/3 repo-settings: pack.useSparse=trueDerrick Stolee via GitGitGadget, Jul 1, 2019
  42. Derrick StoleeJul 8, 2019
  43. Taylor BlauJul 9, 2019
  44. Junio C HamanoJul 9, 2019
  45. Derrick StoleeJul 9, 2019
  46. Junio C HamanoJul 9, 2019
  47. Derrick StoleeJul 22, 2019
  48. Jakub NarebskiJul 11, 2019

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.