[PATCH 5/5] builtin/pack-objects.c: do not open-code `MAX_PACK_OBJECT_HEADER`
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Aug 27, 2024, 21:13 UTC
- Message-ID
- <82754d92509e364e96fe35ca20eb709eb6f38641.1724793201.git.me@ttaylorr.com>
- In-Reply-To
- <cover.1724793201.git.me@ttaylorr.com>
The function `write_reused_pack_one()` defines an header to store the OFS_DELTA header, but uses the constant "10" instead of "MAX_PACK_OBJECT_HEADER" (as is done elsewhere in the same patch, circa bb514de356c (pack-objects: improve partial packfile reuse, 2019-12-18)).
Declare the `ofs_header` field to be sized according to `MAX_PACK_OBJECT_HEADER` (which is 10, as defined in "pack.h") instead of the constant 10.
Signed-off-by: Taylor Blau <me@ttaylorr.com> --- builtin/pack-objects.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/builtin/pack-objects.c b/builtin/pack-objects.c index 700adfb5a8..c6e2852d3c 100644 --- a/builtin/pack-objects.c +++ b/builtin/pack-objects.c @@ -1072,7 +1072,7 @@ static void write_reused_pack_one(struct packed_git *reuse_packfile, fixup = find_reused_offset(offset) - find_reused_offset(base_offset); if (fixup) { - unsigned char ofs_header[10]; + unsigned char ofs_header[MAX_PACK_OBJECT_HEADER]; unsigned i, ofs_len; off_t ofs = offset - base_offset - fixup;
-- 2.46.0.426.g82754d92509