Re: [PATCH 0/4] Build in some more things
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Oct 30, 2007, 08:14 UTC
- Message-ID
- <7vzly1nhmn.fsf@gitster.siamese.dyndns.org>
- In-Reply-To
- <Pine.LNX.4.64.0710292049450.7357@iabervon.org>
I've merged this to 'pu', but honestly speaking, the conflicts are geting a bit more "interesting" than I care to keep repeating even with help from rerere, with four people simultaneously touching the neighbouring code in their topics.
Topics involved are:
** db/remote-builtin (Mon Oct 29 22:03:42 2007 -0400) 4 commits . Use built-in send-pack. . Build-in send-pack, with an API for other programs to call. . Build-in peek-remote, using transport infrastructure. . Miscellaneous const changes and utilities
* jk/send-pack (Thu Oct 18 02:17:46 2007 -0400) 2 commits + t5516: test update of local refs on push + send-pack: don't update tracking refs on error
* js/forkexec (Fri Oct 19 21:48:06 2007 +0200) + Use start_command() in git_connect() instead of explicit fork/exec. + Change git_connect() to return a struct child_process instead of a pid_t.
** sp/push-refspec (Sun Oct 28 18:46:21 2007 +0100) . push: teach push to pass --verbose option to transport layer . push: use same rules as git-rev-parse to resolve refspecs . add ref_abbrev_matches_full_with_rev_parse_rules() comparing abbrev with full ref name . rename ref_matches_abbrev() to ref_abbrev_matches_full_with_fetch_rules()
Could you please check the result after I push it out?