Re: [PATCH] - Updated usage and simplified sub-command action invocation
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 10, 2008, 07:22 UTC
- Message-ID
- <7vzlve6t69.fsf@gitster.siamese.dyndns.org>
- In-Reply-To
- <7bfdc29a0801092251p3d46a3cau3db4d57c4f705043@mail.gmail.com>
"Imran M Yousuf" <imyousuf@gmail.com> writes:
Show 11 quoted lines
> On Jan 10, 2008 12:23 PM, Junio C Hamano <gitster@pobox.com> wrote: > ... >> I somehow feel that syntactically the original implementation >> that allowed subcommand specific options to come before the >> subcommand name was a mistake. It may be easier for users that >> both "-b branch add" and "add -b branch" are accepted, but I >> have to wonder if it would really hurt if we made "-b branch >> add" a syntax error. > > I will recode it to have all options except for --quiet (which is > inverse of -v or --verbose) be mentioned after the subcommand.
Just a word of caution when dealing with me.
Unlike Linus, I am not always right. And other people on the list who are here longer already know this. I am reasonably sure that some of them will disagree with me on design issues like this one; I mildly suspect that this forbidding "-b branch add" might be met with resistance from existing users.
You do not have to agree with me on every little detail I mention. If you feel a design issue might be contentious, it could turn out to be a better use of your time to keep the code as it is while waiting to see if other people would offer better alternatives.
> Actually module_$command is not possible because only add's module is > module_add rest are modules_$command....
Is there a fundamental reason why you cannot rename them to be more consistent?