Re: [PATCH] apply: handle filenames with double slashes better
- From
Junio C Hamano <gitster@pobox.com>
- Date
- May 21, 2009, 19:22 UTC
- Message-ID
- <7vws8a9s7r.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <20090521191204.GA29362@sepie.suse.cz>
Michal Marek <mmarek@suse.cz> writes:
Show 5 quoted lines
> I tried this, but I'm not sure it's better now (and there might be some > inconsistencies left). IMHO removing the double slashes is an operation > similar to the unquoting done in find_name(), i.e. converting the text > in the patch to something that can be passed to lstat() or > cache_name_lookup().
Ok, you convinced me.
Let's take your first patch with just the s/canon_name/squash_slash/ change.
Thanks.