Re: [PATCH v6 00/31] git-remote-mediawiki: Follow perlcritic's recommandations
Célestin Matte <celestin.matte@ensimag.fr> writes:
Show 43 quoted lines
> Célestin Matte (31):
> git-remote-mediawiki: Make a regexp clearer
> git-remote-mediawiki: Move "use warnings;" before any instruction
> git-remote-mediawiki: Replace :utf8 by :encoding(UTF-8)
> git-remote-mediawiki: Always end a subroutine with a return
> git-remote-mediawiki: Move a variable declaration at the top of the
> code
> git-remote-mediawiki: Change syntax of map calls
> git-remote-mediawiki: Rewrite unclear line of instructions
> git-remote-mediawiki: Remove useless regexp modifier (m)
> git-remote-mediawiki: Change the behaviour of a split
> git-remote-mediawiki: Change separator of some regexps
> git-remote-mediawiki: Change style in a regexp
> git-remote-mediawiki: Change style in a regexp
> git-remote-mediawiki: Add newline in the end of die() error messages
> git-remote-mediawiki: Change the name of a variable
> git-remote-mediawiki: Turn double-negated expressions into simple
> expressions
> git-remote-mediawiki: Remove unused variable $entry
> git-remote-mediawiki: Rename a variable ($last) which has the name of
> a keyword
> git-remote-mediawiki: Assign a variable as undef and make proper
> indentation
> git-remote-mediawiki: Check return value of open
> git-remote-mediawiki: remove import of unused open2
> git-remote-mediawiki: Put long code into a subroutine
> git-remote-mediawiki: Modify strings for a better coding-style
> git-remote-mediawiki: Brace file handles for print for more clarity
> git-remote-mediawiki: Replace "unless" statements with negated "if"
> statements
> git-remote-mediawiki: Don't use quotes for empty strings
> git-remote-mediawiki: Put non-trivial numeric values in constants.
> git-remote-mediawiki: Fix a typo ("mediwiki" instead of "mediawiki")
> git-remote-mediawiki: Clearly rewrite double dereference
> git-remote-mediawiki: Add a .perlcriticrc file
> git-remote-mediawiki: add a perlcritic rule in Makefile
> git-remote-mediawiki: Make error message more precise
>
> contrib/mw-to-git/.perlcriticrc | 28 ++
> contrib/mw-to-git/Makefile | 2 +
> contrib/mw-to-git/git-remote-mediawiki.perl | 537 +++++++++++++++-------------
> 3 files changed, 320 insertions(+), 247 deletions(-)
> create mode 100644 contrib/mw-to-git/.perlcriticrc