git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: obstack fails to compile on OS X 10.7

From
Junio C Hamano <gitster@pobox.com>
Date
Aug 29, 2011, 06:07 UTC
Message-ID
<7vty907nud.fsf@alter.siamese.dyndns.org>
In-Reply-To
<20110829031806.GA58338@gmail.com>
David Aguilar <davvid@gmail.com> writes:
Show 5 quoted lines
>> -void obstack_free (struct obstack *__obstack, void *__block);
>> +void obstack_free (struct obstack *obstack, void *block);
>
> Tiny nit: I know it's just a declaration but would it be advisable to
> drop the variable names altogether here?

I agree. In general it is easier to read if parameter names to a function declaration is omitted, especially if it is clear from their types what they mean [*1*]. And in this case, it is.

> Tested-by: David Aguilar <davvid@gmail.com>
Thanks.
[Footnote]
*1* It is Ok to spell them out in a case like this:
    int copy(char *dst, const char *src, size_t);

You do not have to, as "char *" vs "const char *" makes it clear which one is which.

Previous: David AguilarNext: Ramsay Jones
Message 6 of 7 in “obstack fails to compile on OS X 10.7”
  1. Brian GernhardtAug 27, 2011
  2. David AguilarAug 27, 2011
  3. Brian GernhardtAug 28, 2011
  4. Fredrik KuivinenAug 28, 2011
  5. David AguilarAug 29, 2011
  6. Junio C HamanoAug 29, 2011
  7. Ramsay JonesSep 1, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.